network-manager only displays wlan logo with red "!"

Asked by Alessio on 2010-10-07

After done yesterday upgrade from Ubuntu 10.04 to 10.10, I have a problem with network-manager.
On the top panel there only the wlan icon with red exclamation point over, but i'm cable-connected, so it should be a double arrow icon.
Clicking on it says "Disconnected, you're now working offline". Clicking on another time message still the same. So i'm not connected.
I must run sudo dhclient from console to obtain new ip and connect my laptop to internet. Once connected the icon is still wifi with !.
Is it a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Alessio
Solved:
2010-10-07
Last query:
2010-10-07
Last reply:
2010-10-07
Alessio (hypnotize) said : #1

I also tried to disable Wlan network throught hardware button under my laptop, problem still be.

Can you give the output of:

sudo lshw -C network

Thanks

I believe you get the exclamation mark when there are wireless networks around for you to connect to.

Alessio (hypnotize) said : #3

Here it is:

ale@jarvis:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: MCP65 Ethernet
       vendor: nVidia Corporation
       physical id: 6
       bus info: pci@0000:00:06.0
       logical name: eth0
       version: a3
       serial: 00:1b:24:be:b3:0d
       size: 100MB/s
       capacity: 1GB/s
       width: 32 bits
       clock: 66MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 duplex=full ip=192.168.1.7 latency=0 link=yes maxlatency=20 mingnt=1 multicast=yes port=MII speed=100MB/s
       resources: irq:20 memory:f2487000-f2487fff ioport:30e0(size=8)
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:16 memory:f2000000-f2003fff
  *-network:0 DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:1a:73:b8:13:d3
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=2.6.35-22-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
  *-network:1
       description: Ethernet interface
       physical id: 2
       logical name: vboxnet0
       serial: 0a:00:27:00:00:00
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes
ale@jarvis:~$

If you right click the icon, you can disable the wireless for a smoother day, otherwise not sure. Your ethernet does have a connection as yuo can see it has an IP address

Alessio (hypnotize) said : #5

If i disable network (or re-enable) always i see only wifi icon, i'd like to see double arrow icon.
Last, problem still be as i've wrote in first post.

not sure then dude, I use wicd as I find it more flexible than network-manager. It's also DE independant

Maybe someone else can contribute

Alessio (hypnotize) said : #7

Stopped using network-manager, installed Wicd that works fine.
Thanks for help.