Network manager unmanaged

Asked by Nigel Dean on 2010-07-12

I'm using Ubuntu 10.04 (I think - can't find anywhere to confirm) running KDE. wireless network was working fine, but for some reason it is now 'unmanaged' and I can't get an internet connection.
I've tried commenting out everything in /etc/network/interfaces AND setting managed=true in /etc/NetworkManager/nm-system-settings.conf, but it is still unmanaged after network-manager restart and a reboot. I hadn't installed new software or added any system upgrades so I have no idea how this happended. Curiously at about the same time this started a 'search service' applet appeared on the 'task bar' which I don't remember asking for.
Any ideas how to proceed?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2010-07-15
Last query:
2010-07-15
Last reply:
2010-07-14

If you use /etc/network/interfaces for the device then network manager will not be able to touch it (or any other gui app). You only need 2 lines in /etc/network/interfaces to configure the loop back device and thats all.

auto lo
iface lo inet loopback

That is the only 2 lines you want.

Nigel Dean (ndean100) said : #2

The 2 lines

auto lo
iface lo inet loopback

are the only ones in /etc/network/interfaces. However, even with managed=true in /etc/NetworkManager/nm-system-settings.conf I still can't get a network connection. Or at least not a consistent one, last night it worked, but this morning it wouldn't resume from 'Sleep' mode - when I rebooted it was back in unmanaged mode.

Install wicd using a wired connection, see if it's nicer.

Nigel Dean (ndean100) said : #4

Thanks actionparsnip, that solved my question.