Default Key Ring Prompts for Password

Asked by Charlene Tessier on 2010-03-02

Hello all!

My problem is similar to this past post:

"password request for networkmanager at start up

   1. Ubuntu
   2. “network-manager” package
   3. Questions
   4. Question #60000

At the end of start up I am asked for my password for default key ring network manager applet (/usr/bin/nm-applet). It wants access to default key ring but it is locked.

This is the only start up password request I receive. I use a laptop and wireless. Can you help me set the password to be automatically entered, rather than typing it every time I start up."

I'm using 9.04 desktop version on a Sony laptop and have a wifi usb which is all working. Its just very annoying to have to always type in the password. If I could set it to do it automatically that would be great. Question #60000 was reported as a bug; However the date is prior to 9.04 and I would like to know if this has been fixed.

Many Thanks from Vancouver,

Charlene

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
George Standish
Solved:
2010-03-02
Last query:
2010-03-02
Last reply:
2010-03-02

I'm guessing you have Autologin turned on.

If you disable Autologin and type your password when you log in - then the Key Ring will NOT come up. You can test System / Admin / Login Screen - and turn autologin off - when you re-login the key ring won't come up, only the initial login.

This is a security setting, if someone steals your laptop do you really want them to get ALL you passwords included in the keyring? So, you have to type your password at least once, where (either GDM login, or Key Ring for nm-applet) is up to you.

Best of luck.

Charlene Tessier (cmmtessier) said : #2

Thanks George Standish, that solved my question.

Charlene Tessier (cmmtessier) said : #3

Many Thank yous,

This makes sense. I'll give it a try.

Thank you,

Charlene