VPN disabled Issue

Asked by Fedor on 2009-04-20

I am NOT an Ubuntu Pro, so when replying please take it under consideration. I am running Ubuntu 8.04 (if I am not mistaken) on Dell-Mini. I've setup VPN and used it without problems for a few months until I've decided to install the latest update (update manager updates that notify you automatically) last week. From that point on, I could not run my VPN, I was getting a message that something (!) is disabled. I've removed my existing VPN configuration, and I can no longer add another one as VPN Add Option is disabled (inside VPN Configuration). Following some Google posts, I've added VPNC and OpenVPN clients/protocols (whatever they are technically called) either via Add/Remove or via sudo command prompt. I've rebooted and yet my VPN configuration is still disabled.
I would really appreciate your help!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager-openvpn Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-22
Last reply:
2009-04-23
Tom (tom6) said : #1

System - Administration - Synaptic Package Manager

then normal user password, not SuperUser/Root one and then click on the menu

Edit - Fix Broken Packages

Hope this helps!
Good luck and regards from
Tom :)

Fedor (2009-ralfn) said : #2

Thanks, Tom. I've tried that and nothing has changed, unless you recommend to reboot again and try to install VPNC and/or OpenVPN again...

Fedor (2009-ralfn) said : #3

By the way, here is the log from the automatic update (that was done a few days ago) that I found in Synaptic Package Manager:

Commit Log for Thu Apr 16 10:05:32 2009

Upgraded the following packages:
libdrm2 (2.3.0.16-0ubuntu2~804um3) to 2.3.0.23+repack-0netbook4
libgl1-mesa-dri-psb (0.18) to 0.24+repack+0038.1-0netbook1
linux-image-lpia (2.6.24.19.21) to 2.6.24.22.24-0netbook1
linux-lpia (2.6.24.19.21) to 2.6.24.22.24-0netbook1
linux-restricted-modules-common (2.6.24.13-19.45netbook5) to 2.6.24.14-22.53netbook4
linux-restricted-modules-lpia (2.6.24.19.21) to 2.6.24.22.24-0netbook1
psb-video (0.22-4usg1) to 0.28+0038-0netbook1
update-manager (1:0.87.30netbook0belmont2) to 1:0.87.30netbook0belmont3
update-manager-core (1:0.87.30netbook0belmont2) to 1:0.87.30netbook0belmont3
xorg-modules-xpsb (0.10-7) to 0.16+0038-0netbook1
xserver-xorg-video-psb (0.16.0+repack-0ubuntu1~804um5netbook1) to 0.27.0+repack-0netbook2

Installed the following packages:
canonical-oem-keyring (2009.02.19)
linux-image-2.6.24-22-lpia (2.6.24-22.45netbook9)
linux-restricted-modules-2.6.24-22-lpia (2.6.24.14-22.53netbook4)
linux-ubuntu-modules-2.6.24-22-lpia (2.6.24-22.35netbook26)

Tom (tom6) said : #4

Rebooting is rarely necessary just for installing stuff in linux. Sometimes i go as far as logging out and back in again but i only reboot sometime after the blue cicle arrows appear in the top taskbar by the clock. Sometimes i get carried away and completely forget to reboot for hours but really rebooting shouldn't be needed except rarely.

I was hoping my quick easy answer would help :( Networking is waaay out of my league and VPN sounds like a huge step up from that.

The responses to this are a bit sparse at the moment so here's some other places worth trying too
https://help.ubuntu.com/community/HowToGetHelp

Good luck and regards from
Tom :)

Fedor (2009-ralfn) said : #5

I've noticed that I can install network-manager-gnome with no issues, but when I try to install network-manager-pptp (together with gnome) it fails.
Here is the error:

Conflicts: network-manager-pptp (< 0.7 ~~) but 0.6.5+svnhead2574-0ubuntul is to be installed
E: broken packages

If I try to install network-manager-pptp on its own, it uninstalls network-manager and network-manager-gnome and then everything fails - wired, wireless

Do these 2 packages co-exist together?

jari (jaript) said : #6

They should co-exist, and do in Jaunty at least. From the error message it seems the network-manager-gnome you have installed is a later version (one from Intrepid or Jaunty). Please check your apt sources to verify they only refer to one Ubuntu version, do "sudo apt-get update" and install the same version of all network-manager parts. Assuming you are to stay in Hardy, try this:
sudo apt-get install network-manager=0.6.6-0ubuntu5 network-manager-gnome=0.6.6-0ubuntu3.1 network-manager-pptp

That should downgrade the network-manager. Alternatively you could put Intrepid repository to the apt sources, install network-manager-pptp, and then change the apt sources back...
Best of luck!

Tom (tom6) said : #7

Errr, i couldn't make much sense of that but it looked quite probable! I think it might be good if you could copy and paste the contents of

/etc/apt/sources.list

To do this go up to the top taskbar and click on

Applications - Accessories - Terminal

and into the terminal/command window/console type (or copy and mouse-paste

gedit /etc/apt/sources.list

and then copy and paste the contents of that text-file into here.
Good luck with this!
Regards from
Tom :)

Fedor (2009-ralfn) said : #8

Jari,
Since I am quite new to Ubuntu, I am not installing any packages from newer versions yet. Anything I load comes from the automatic updates (from dell). Here is the output of:

$ sudo apt-get update
(as you can see - these are all seem to be Hardy release, right?)

Hit http://dell-mini.archive.canonical.com hardy Release.gpg
Ign http://dell-mini.archive.canonical.com hardy/main Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy/universe Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy/multiverse Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy/restricted Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy-updates Release.gpg
Ign http://dell-mini.archive.canonical.com hardy-updates/main Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-updates/universe Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-updates/multiverse Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-updates/restricted Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy-security Release.gpg
Ign http://dell-mini.archive.canonical.com hardy-security/main Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-security/universe Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-security/multiverse Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-security/restricted Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy-netbook-base Release.gpg
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/main Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/universe Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/multiverse Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/restricted Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy-dell-mini Release.gpg
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/main Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/universe Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/multiverse Translation-en_US
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/restricted Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy-dell-mini Release.gpg
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/public Translation-en_US
Hit http://dell-mini.archive.canonical.com hardy Release
Hit http://dell-mini.archive.canonical.com hardy-updates Release
Hit http://dell-mini.archive.canonical.com hardy-security Release
Hit http://dell-mini.archive.canonical.com hardy-netbook-base Release
Hit http://dell-mini.archive.canonical.com hardy-dell-mini Release
Hit http://dell-mini.archive.canonical.com hardy-dell-mini Release
Hit http://dell-mini.archive.canonical.com hardy/main Packages
Hit http://dell-mini.archive.canonical.com hardy/universe Packages
Hit http://dell-mini.archive.canonical.com hardy/multiverse Packages
Hit http://dell-mini.archive.canonical.com hardy/restricted Packages
Hit http://dell-mini.archive.canonical.com hardy/main Sources
Hit http://dell-mini.archive.canonical.com hardy/universe Sources
Hit http://dell-mini.archive.canonical.com hardy/multiverse Sources
Hit http://dell-mini.archive.canonical.com hardy/restricted Sources
Hit http://dell-mini.archive.canonical.com hardy-updates/main Packages
Hit http://dell-mini.archive.canonical.com hardy-updates/universe Packages
Hit http://dell-mini.archive.canonical.com hardy-updates/multiverse Packages
Hit http://dell-mini.archive.canonical.com hardy-updates/restricted Packages
Hit http://dell-mini.archive.canonical.com hardy-updates/main Sources
Hit http://dell-mini.archive.canonical.com hardy-updates/universe Sources
Hit http://dell-mini.archive.canonical.com hardy-updates/multiverse Sources
Hit http://dell-mini.archive.canonical.com hardy-updates/restricted Sources
Hit http://dell-mini.archive.canonical.com hardy-security/main Packages
Hit http://dell-mini.archive.canonical.com hardy-security/universe Packages
Hit http://dell-mini.archive.canonical.com hardy-security/multiverse Packages
Hit http://dell-mini.archive.canonical.com hardy-security/restricted Packages
Hit http://dell-mini.archive.canonical.com hardy-security/main Sources
Hit http://dell-mini.archive.canonical.com hardy-security/universe Sources
Hit http://dell-mini.archive.canonical.com hardy-security/multiverse Sources
Hit http://dell-mini.archive.canonical.com hardy-security/restricted Sources
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/main Packages
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/universe Packages
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/multiverse Packages
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/restricted Packages
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/main Sources
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/universe Sources
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/multiverse Sources
Ign http://dell-mini.archive.canonical.com hardy-netbook-base/restricted Sources
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/main Packages
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/universe Packages
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/multiverse Packages
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/restricted Packages
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/main Sources
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/universe Sources
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/multiverse Sources
Ign http://dell-mini.archive.canonical.com hardy-dell-mini/restricted Sources
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/public Packages
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/public Sources
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/main Packages
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/universe Packages
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/multiverse Packages
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/restricted Packages
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/main Sources
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/universe Sources
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/multiverse Sources
Hit http://dell-mini.archive.canonical.com hardy-netbook-base/restricted Sources
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/main Packages
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/universe Packages
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/multiverse Packages
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/restricted Packages
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/main Sources
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/universe Sources
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/multiverse Sources
Hit http://dell-mini.archive.canonical.com hardy-dell-mini/restricted Sources
Reading package lists... Done

Now, your second installation command produces the following not-found error:
$ sudo apt-get install network-manager=0.6.6-0ubuntu5 network-manager-gnome=0.6.6-0ubuntu3.1 network-manager-pptp
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '0.6.6-0ubuntu3.1' for 'network-manager-gnome' was not found

What else can I try?

Fedor (2009-ralfn) said : #9

Tom,
Here are the contents of the source.list

deb http://dell-mini.archive.canonical.com/ubuntu/ hardy main universe multiverse restricted
deb-src http://dell-mini.archive.canonical.com/ubuntu/ hardy main universe multiverse restricted

deb http://dell-mini.archive.canonical.com/ubuntu/ hardy-updates main universe multiverse restricted
deb-src http://dell-mini.archive.canonical.com/ubuntu/ hardy-updates main universe multiverse restricted

deb http://dell-mini.archive.canonical.com/ubuntu/ hardy-security main universe multiverse restricted
deb-src http://dell-mini.archive.canonical.com/ubuntu/ hardy-security main universe multiverse restricted

deb http://dell-mini.archive.canonical.com/ubuntu/ hardy-netbook-base main universe multiverse restricted
deb-src http://dell-mini.archive.canonical.com/ubuntu/ hardy-netbook-base main universe multiverse restricted

deb http://dell-mini.archive.canonical.com/ubuntu/ hardy-dell-mini main universe multiverse restricted
deb-src http://dell-mini.archive.canonical.com/ubuntu/ hardy-dell-mini main universe multiverse restricted

Tom (tom6) said : #10

That is all looking annoyingly perfect! lol. I really thought Jari was onto something there :(
However, it could be just one of those possibilities worth discounting quickly before moving on.

Good luck with this
Regards from
Tom :)

Fedor (2009-ralfn) said : #11

yeah, it was worth a try...

jari (jaript) said : #12

Odd... Could you type the following to a terminal and paste here the output:
dpkg -l network-manager network-manager-gnome network-manager-pptp

and on the other hand:
apt-cache show network-manager-pptp

Fedor (2009-ralfn) said : #13

Output of the 1st command:
$ dpkg -l network-manager network-manager-gnome network-manager-pptp
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii network-manage 0.7~~svn200810 network management framework daemon
ii network-manage 0.7~~svn200810 network management framework (GNOME frontend
rc network-manage 0.6.5+svnhead2 network management framework (PPTP plugin)

Output of the 2nd command:
$ apt-cache show network-manager-pptp
Package: network-manager-pptp
Priority: optional
Section: universe/net
Installed-Size: 924
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Craig Box <email address hidden>
Architecture: lpia
Version: 0.6.5+svnhead2574-0ubuntu1
Depends: pptp-linux, libart-2.0-2 (>= 2.3.18), libatk1.0-0 (>= 1.13.2), libbonobo2-0 (>= 2.15.0), libbonoboui2-0 (>= 2.15.1), libc6 (>= 2.6-1), libcairo2 (>= 1.4.0), libdbus-1-3 (>= 1.1.1), libdbus-glib-1-2 (>= 0.74), libfontconfig1 (>= 2.4.0), libgconf2-4 (>= 2.13.5), libglade2-0 (>= 1:2.6.1), libglib2.0-0 (>= 2.14.0), libgnome-keyring0 (>= 2.19.6), libgnome2-0 (>= 2.17.3), libgnomecanvas2-0 (>= 2.19.1), libgnomeui-0 (>= 2.19.1), libgnomevfs2-0 (>= 1:2.17.90), libgtk2.0-0 (>= 2.11.6), libice6 (>= 1:1.0.0), libnm-util0, liborbit2 (>= 1:2.14.8), libpango1.0-0 (>= 1.18.1), libpopt0 (>= 1.10), libsm6, libx11-6, libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3 (>= 1:4.0.1), libxi6, libxinerama1, libxml2 (>= 2.6.29), libxrandr2 (>= 2:1.2.0), libxrender1
Filename: pool/universe/n/network-manager-pptp/network-manager-pptp_0.6.5+svnhead2574-0ubuntu1_lpia.deb
Size: 127232
MD5sum: 8b9cdae3bd6648ae7a4cc834939ab47b
SHA1: 60e6837b31f303545c702512ea52ff692b47fd61
SHA256: db1425d35d7cf9b8b0fb9a21d687660aae674c5329613a220ec3689c39736d05
Description: network management framework (PPTP plugin)
 NetworkManager attempts to keep an active network connection available at
 all times. It is intended primarily for laptops where it allows easy
 switching betwen local wireless networks, it's also useful on desktops
 with a selection of different interfaces to use. It is not intended for
 usage on servers.
 .
 This package provides a VPN plugin for PPTP, commonly used for connecting
 to Microsoft VPN servers.
Bugs: mailto:<email address hidden>
Origin: Ubuntu

jari (jaript) said : #14

That's pretty strange, as the package even in the Dell mini-archive seems to be version 0.66 rather than the 0.7 you have installed. In any case it should work by installing what's in the archives:

sudo apt-get install network-manager-gnome=0.6.6-0ubuntu3usg5 network-manager=0.6.6-0ubuntu5 network-manager-pptp

That's assuming the VPN is actually a Microsoft VPN... otherwise it might be in network-manager-vpnc or network-manager-openvpn. You can also install them all.

Do note that this does downgrade network manager and the 0.66 version isn't quite as nice as 0.7. I guess you could also get the source package from Intrepid and compile but that's a little more complicated.

Best of luck!

Tom (tom6) said : #15

As this question is now 3 days old and considering what's likely to happen tomorrow i recommend re-posting this question asap today.

https://answers.launchpad.net/ubuntu/+addquestion

There are always new people appearing at the front-desk so it's worth trying again with this one i think. i only filed this as "network-manager-openvpn" because it was the only vpn folder i could fit it in! Anyway i think we have explored quite a few things (thanks Jari :) ) which will hopefully help make the new question quite short & quick, perhaps linking back to the info supplied here using the url link
https://answers.launchpad.net/ubuntu/+source/network-manager-openvpn/+question/68045

Good luck and regards from
Tom

PS Please don't mark this one as solved by this posting as it wont help the "Solved Answers" database, yet

Can you help with this problem?

Provide an answer of your own, or ask Fedor for more information if necessary.

To post a message you must log in.