Authorization not prompted on VPN connection with imported config

Asked by Oxwivi on 2011-02-28

I'm trying to use a free service using the OpenVPN protocol using OpenVPN's GUI module in the network manager.

The config worked perfectly well as .ovpn on Windows. The behavior in Windows is such that I ran OpenVPN GUI and chose to connect to this particular VPN. It would then show the activity in the attempt to connect and opens a dialog box for username/password authentication.

I've successfully imported all the configurations after changing the file type to .conf and using the import feature in network manager. However, attempting to connect would simply display the network manager's attempting to connect animation, but ultimately end with a notification of connection timing out. No prompt asking for authentication would appear at all, nor can I find any feature to prefix the authentication details.

The configuration file is as follows:
____________________________________________________________________________________
client
dev tun
proto tcp
remote miami.proxpn.com 443
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert client.crt
key client.key
cipher BF-CBC
keysize 512
comp-lzo
verb 4
mute 5
tun-mtu 1500
mssfix 1450
auth-user-pass
reneg-sec 0

# If you are connecting through an
# HTTP proxy to reach the actual OpenVPN
# server, put the proxy server/IP and
# port number here. See the man page
# if your proxy server requires
# authentication.
;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]
____________________________________________________________________________________

Needless to say, but I've downloaded all the required packages for setting up OpenVPN connections.

By the way, as you can see above, .key and .crt files location are specified to be in the same directory as the config file. After importing the config file, if I were to remove them, would it cause any problem? Note, I haven't removed them, so the problem I'm facing is not due to the absence of these files.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-openvpn Edit question
Assignee:
No assignee Edit question
Solved by:
Oxwivi
Solved:
2011-03-03
Last query:
2011-03-03
Last reply:
Oxwivi (oxwivi) said : #1

I had to add myself to the netdev group to use this connection and choose TLS with authentication.