WPA2 password is not stored

Asked by Carolyn on 2009-11-02

I'm new to linux and unable to log onto a WPA2 protected wireless ...

I enter the password using "show password" and see it's correct. When I return and click "show password" - I see a string of jibberish characters running off screen. If I try to connect to the network, I'm repeatedly asked for the password.

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Krüger
Solved:
2009-11-03
Last query:
2009-11-03
Last reply:
2009-11-02
Best Thomas Krüger (thkrueger) said : #1

There are two ways to represent a WPA2 password. At first there is the normal version, the password as you know it. This password can be run through something called a hash algorithm together with den networks ESSID and you get that long string you have seen. You can conenct to the network with both. Ubuntu stores and uses the hashed version.
There have been some questions about password storing for WLANs in the last few days. There may be a bug in the network manager.
If you are unable to store the password you should report this as a bug.

Carolyn (ubuntu-musikos) said : #2

Thanks Thomas Krüger, that solved my question.