Network Manager Icon Gone

Asked by Hail Holy Ghost on 2009-07-17

I'm running Intrepid Ibex.

A while back I accidentally deleted the Network Manager Icon on the upper right corner of GNOME, and haven't been able to get it back.

I've looked in many different launchpad/Ubuntu help blogs, and I decided that I could reinstall Network Manager (NM) through the Add/Remove icon in "Applications", restart the computer, and it would appear. Not the case!

Then I tried to initialize it from the command line

"david@david-laptop:~$ sudo /etc/init.d/NetworkManager start
[sudo] password for david:
 * Starting NetworkManager... [fail]"

I then tried logging in from a guest session, and the icon doesn't appear there either.

Then I read that the manager doesn't appear when there is an ethernet connect, which I'm using now, so I disconnected that. No NM icon showed. Then I tried restarting without the ethernet connection. No dice.

There is another piece of advice I saw that tells me to delete etc/network/interfaces, and I tried deleting that, but it wouldn't let me. So I went back into the terminal to log in as root, and it still said

"You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again."

I am no big fan of wireless, I've had a lot of problems with it over the years, but wireless is, unfortunately, a necessity nowadays.

It seems like such a trivial problem but it is seriously disabling.

I've posted this problem several times on Ubuntu Support, but gotten no answer.

Any help is greatly appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Vihar
Solved:
2009-07-20
Last query:
2009-07-20
Last reply:
2009-07-18
Best Vihar (vmankov) said : #1

There are several ways to try to get it back:

--Right-click on the upper panel, choose +Add to Panel and look there to find something proper. Also you can try there to load "Notification Area". If something unwanted appears you just delete it.

--Look in Configuration Editor-->apps-->nm-applet. The value of "stamp" should be 1. You can change it by double-clicking. Run Configuration Editor in terminal by

gconf-editor

--Try to see what happens when you run in terminal

nm-applet

--Finally you can reinstall all gnome-panel by Synaptic Manager.

Vihar (vmankov) said : #2

One more way is going System-->Preferences and right-clicking on Network Connections but i'm not sure this will embed it in Notification area.

Hail Holy Ghost (dec86) said : #3

"--Right-click on the upper panel, choose +Add to Panel and look there to find something proper. Also you can try there to load "Notification Area". If something unwanted appears you just delete it."

THANK YOU SO MUCH Vihar!!!!!!

Re-loading the notification area worked beautifully!!!

Hail Holy Ghost (dec86) said : #4

Thanks Vihar, that solved my question.

Vihar (vmankov) said : #5

Have a joy with Linux.
Cheers!