How to allow 2 connections at the same time in Network Manager?

Asked by DARK_Vovich on 2009-01-28

I wonder how to allow 2 connections at the same time in Network Manager in Ubuntu 8.10?

I have local connection and internet connection (pppoe), but they work only individually.

I have now (picture): http://pic.ipicture.ru/uploads/090128/11894/UXqONKmMRi.png

But i want (picture): http://pic.ipicture.ru/uploads/090119/11894/2tF3tAFEXU.jpg (is a bug)

Help me please!

P.S.: not to propose pppoeconf or quagga )

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-29
Last reply:
2009-02-07
Ariel Cabral (acabral1961) said : #1

Please, excuse me for the basic question.
How many networks cards do you have? (The picture shows only one)
Because if you have only one net card you can't do it.
Can you please open a terminal and type:
 sudo ifconfig -a
and then paste the output here.
Hope this helps, let me know.

DARK_Vovich (darkvovich) said : #2

Yes, i have only 1 ethernet adapter. In windows i could have 2 connections at same time, do so not in Ubuntu?

 sudo ifconfig -a :

eth0 Link encap:Ethernet HWaddr 00:19:66:74:97:8f
          inet6 addr: fe80::219:66ff:fe74:978f/64 Диапазон:Ссылка
          ВВЕРХ BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:19289 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25902 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:1000
          RX bytes:8045014 (8.0 MB) TX bytes:13544397 (13.5 MB)
          Прервано:22 Base address:0xb800

lo Link encap:Локальная петля (Loopback)
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Диапазон:Узел
          ВВЕРХ LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

pan0 Link encap:Ethernet HWaddr ee:25:df:fe:34:2b
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ppp0 Link encap:Протокол PPP (Point-to-Point Protocol)
          inet addr:192.168.103.5 P-t-P:192.168.103.1 Mask:255.255.255.255
          ВВЕРХ POINTOPOINT RUNNING NOARP MULTICAST MTU:1480 Metric:1
          RX packets:18371 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25826 errors:0 dropped:0 overruns:0 carrier:0
          коллизии:0 txqueuelen:3
          RX bytes:7552204 (7.5 MB) TX bytes:12968273 (12.9 MB)

Ariel Cabral (acabral1961) said : #3

Ok, then you want to assign a IP alias to a netwok card, you can assign up 254 to the same network card.
You can take a look at:
http://www.cyberciti.biz/tips/ubuntu-linux-creating-ethernet-alias-for-eth0-network-device.html
Hope this helps, let me know.

Ariel Cabral (acabral1961) said : #4

From the link I mentioned before and for the record:

To create alias for eth0 use ifconfig command. It is use to configure a network interface and aliases.

Temporary solution:
Assuming that your eth0 IP is 192.168.1.10 and you would like to create an alias eth0:0 with IP 192.168.1.11. Type the following command:

sudo ifconfig eth0:0 192.168.1.11 up

OR

sudo /sbin/ifconfig eth0:0 192.168.1.11 up

Verify that alias is up and running using following two command(s):

/sbin/ifconfig
ping 192.168.1.11
ping your-getway-ip
Permanent configuration

Your ethernet configuration is located in a file called /etc/network/interfaces. If you reboot system you will lost your alias. To make it permanent you need to add it network configuration file:

gksudo gedit /etc/network/interfaces

OR

sudo vi /etc/network/interfaces

Append the following configuration:

auto eth0:0
iface eth0:0 inet static
name Ethernet alias LAN card
address 192.168.1.11
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0

Save the file and restart system or restart the network:

sudo /etc/init.d/networking restart

Please note that you can also use graphical tools located at System > Administration > Networking menu. Or use the following GUI tool to setup aliases, hostname, dns settings etc:

sudo network-admin

If you want more network aliases, use eth0:1, eth0:2, eth0:N (max upto 254).

Ariel Cabral (acabral1961) said : #5

If you want a graphical way (I prefer the console way and i didn't used on 8.10), you must go to System->Preferences->Network Configuration
Then, choose the wired tab and male a click on your network card (Auto eth0) and then click on the Edit button.
When the Editing Auto eth0 opens, choose the IPv4 Settings tab and there you can add your alternative IP configurations.
Hope this helps, let me know.

Tom (tom6) said : #6

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask DARK_Vovich for more information if necessary.

To post a message you must log in.