nm-applet won't respond to some clicks after a while

Asked by Marlon Nelson on 2012-05-12

This was a problem for me in 11.04. I've recently upgraded to 12.04 and it is still a problem.

I'm running Ubuntu 12.04 on a System76 Lemur UltraThin laptop.

Everything starts out OK. I can click on the nm-applet icon and the menu appears and clicking on things on the menu works as expected.

After a while, though, I can't bring up the windows for "Connection Information" or "Edit Connections..." I click on them, and the menu goes away but no windows open.

I've set up the following alias to restart the applet (it works well but it's a PITA):

    alias renm='killall nm-applet ; nm-applet &'

I've also tried running nm-applet in a terminal window to see if any error messages show up, but I get nothing.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Marlon Nelson
Solved:
2012-05-12
Last query:
2012-05-12
Last reply:
2012-05-12

Did you upgrade directly from Natty to Precise using upgrade, or did you remove Natty and clean install Precise?

Marlon Nelson (marlon-nelson) said : #2

I first upgraded from 64-bit 11.04 (with all updates) to 11.10, and then to
12.04, using the alternate disk images.

I had avoided 11.10 because it seemed to make my router to crash when
connecting via wifi.

So, to get to 12.04, I followed the following steps:

1) sudo apt-get update ; sudo apt-get upgrade
2) disconnected from the network
3) mounted the 11.10 amd64 disk image and upgraded
4) connected to the router with an ethernet cable and did the apt-get
update and upgrade
5) mounted the 12.04 amd64 disk image and upgraded
6) reconnected to the network via wifi and did the apt-get update & upgrade

I may have skipped step #4 (my memory is a bit hazy)

On Sat, May 12, 2012 at 7:45 AM, actionparsnip <
<email address hidden>> wrote:

> Your question #196982 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/196982
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Did you upgrade directly from Natty to Precise using upgrade, or did you
> remove Natty and clean install Precise?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/196982
>
> You received this question notification because you asked the question.
>

--
-eom-

do you use 3G connectivity

Marlon Nelson (marlon-nelson) said : #4

I do not use 3G.

I only use WiFi and Ethernet connections.

The device I usually connect to is an Actiontec MI424WR router. See http://www.actiontec.com/products/product.php?pid=189

I don't recall if I've experienced the problem or not when connecting to other devices, or when connected with Ethernet.

Install wicd, then uninstall all network-manager apps. Reboot and you can use wicd.

Marlon Nelson (marlon-nelson) said : #6

no thanks

Marlon Nelson (marlon-nelson) said : #7

Is there any way to run nm-applet in debug mode, in order to get more info on what's happening?

Marlon Nelson (marlon-nelson) said : #8

I found a bunch of bugs that appear related to this problem. So I'll click on "Problem Solved" even though it isn't.

Here's the 1st one I found. It leads to others. https://bugs.launchpad.net/bugs/684599