When I open my sessions, I have 5 nm-applets running, I want one

Asked by Paul Dufresne on 2007-11-29

Now, every time I open my sessions, I have 5 nm-applets that appear.
This began yesterday, the network-manager bug day, which I participated.
The only thing I see is that I have started, and stop NetworkManager.

paul@paul-desktop:~$ dpkg -l | grep network-manager
ii network-manager 0.6.5-0ubuntu17 network management framework daemon
ii network-manager-gnome 0.6.5-0ubuntu10 network management framework (GNOME frontend

paul@paul-desktop:~$ ps aux|grep nm-applet
paul 11818 0.0 1.6 47892 16860 ? S 00:48 0:00 nm-applet --sm-config-prefix /nm-applet-hvNl3w/ --sm-client-id 117f000101000119622361000000052450005 --screen 0
paul 11819 0.0 1.1 42660 11372 ? S 00:48 0:00 nm-applet --sm-config-prefix /nm-applet-G7Yifx/ --sm-client-id 117f000101000119622623500000052450006 --screen 0
paul 11820 0.0 1.4 45688 14916 ? S 00:48 0:00 nm-applet --sm-config-prefix /nm-applet-EC8bCx/ --sm-client-id 117f000101000119622630100000052450008 --screen 0
paul 11821 0.0 1.1 42660 11368 ? S 00:48 0:00 nm-applet --sm-config-prefix /nm-applet-vcG2ix/ --sm-client-id 117f000101000119622626000000052450007 --screen 0
paul 11855 0.0 1.1 42656 11308 ? S 00:48 0:00 nm-applet --sm-disable
paul 12064 0.0 0.0 1760 528 pts/0 R+ 01:43 0:00 grep nm-applet
paul@paul-desktop:~$

paul@paul-desktop:~$ ps aux|grep Network
root 4741 0.0 0.1 4408 1944 ? Ss Nov28 0:00 /usr/sbin/NetworkManager --pid-file /var/run/NetworkManager/NetworkManager.pid
root 4754 0.0 0.1 3264 1160 ? Ss Nov28 0:00 /usr/sbin/NetworkManagerDispatcher --pid-file /var/run/NetworkManager/NetworkManagerDispatcher.pid

I first thought it was because I had activated 'Automatically remember running applications when logging out' in System/Preferences/Session, but then I disable it, killed the nm-applet, then, push 'Remember currently running applications' in session window, then try to log out then log in, but the 5 applets where back.

I need help to get rid of the 4 (in excess) nm-applets for good.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Dufresne
Solved:
2007-11-29
Last query:
2007-11-29
Last reply:
Paul Dufresne (paulduf) said : #1
Paul Dufresne (paulduf) said : #2

Well, I have edited my .gnome2/session file (I am on Hardy).
Commenting out (appending #, not sure it is ok at all), but it seems to work.
I had tried before in System/Preferences/Session, current session to remove the nm-applet there, but it was coming back on next logon.
I have also uncheck in System/Preferences/Session, Startup programs tab, NetworkManager.
Not sure it was necessary.

paul@paul-desktop:~$ cat .gnome2/session

[Default]
#0,id=117f000101000119622361000000052450005
#0,RestartStyleHint=1
#0,Program=nm-applet
#0,CurrentDirectory=/home/paul
#0,CloneCommand=nm-applet --sm-config-prefix /nm-applet-hvNl3w/
#0,RestartCommand=nm-applet --sm-config-prefix /nm-applet-hvNl3w/ --sm-client-id 117f000101000119622361000000052450005 --screen 0
#1,id=117f000101000119622623500000052450006
#1,RestartStyleHint=1
#1,Program=nm-applet
#1,CurrentDirectory=/home/paul
#1,CloneCommand=nm-applet --sm-config-prefix /nm-applet-G7Yifx/
#1,RestartCommand=nm-applet --sm-config-prefix /nm-applet-G7Yifx/ --sm-client-id 117f000101000119622623500000052450006 --screen 0