Slow Internet Speed Wireless Wlan0 iface 11.10 Desktop

Asked by Ging on 2011-12-24

I was using Ubuntu 11.04 Desktop for a over a month and it work fined during first few weeks. However after 11.10 came out I was having Internet Speed problems. But I never upgrade to 11.10. So I look for fix on the Internet the fixed it recommend editing the sysctl.conf file So I did. And again it worked fine for few days. Until Internet speed drop again to 8kbyte that the max I am getting.
So I decided to wipe my machine clean because Ubuntu One allows to save data. And I was back to 11.04. And it work fine again Until 2 days later it went slow again. I know the speed works fine once the Machine comes on the first time on the Internet.
Some other folks are having the same problem
http://www.hitxp.com/articles/software/ubuntu-fix-slow-wireless-internet-connection-speed-upgrading-11-04-natty-narwhal/
Other problems are sudo /wconfig does not work but sudo iwconfig does work, Normally I can do a interface down and then the Interface up If it is a network IOS but on desktop sudo ifup and ifdown does not work on any Interface including wlan0 But it only works on lo interface.(loopback)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Ging
Solved:
2011-12-31
Last query:
2011-12-31
Last reply:
2011-12-24
Ging (rjndr0) said : #1

I then again re-partition my Hard drive and Reinstall 11.04 and Upgraded to 11.10 via Download Internet. It took only 4 hours but I manage to upgrade it to 11.10 it was working at good speed for a while few hours later the speed went slow again. So wiping the machine clean and upgrading to 11.10 appears to fix the problem ONLY for Problem to return BACK in 11.10 Ubuntu in just few hours. It seems either there is some Artificial Intelligent Script that design to heal or optimized the performance including the Internet speed is NOT working.

try 8.8.8.8 as name server. may help?

Ging (rjndr0) said : #3

I tried changing the DNS server to 8,8.8.8 and also used OpenDNS
server with no change
Here is more informaton
wlan0 IEEE 802.11abg ESSID:"GNN"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:12:17:CB:59:EF
          Bit Rate=54 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=61/70 Signal level=-49 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:2652 Missed beacon:0
Notice it show 54Mb/s but I can only get 8byte per second that too is choppy.

On 12/24/11, actionparsnip <email address hidden> wrote:
> Your question #182814 on gnome-system-monitor in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-system-monitor/+question/182814
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> try 8.8.8.8 as name server. may help?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/gnome-system-monitor/+question/182814
>
> You received this question notification because you asked the question.
>

Ging (rjndr0) said : #4

Futher analysis shows that once download is started it slows down considerably however if stop button is click from firefox download button it does stop, and picks up speed only to slow down again after few seconds. This stop and start of download is much faster way to download then regular download.

Ging (rjndr0) said : #5

I found the problem thanks to the Internet, and Google search. It seems that IBM thinkpad Lenovo X60 is having problems with wireless Intel card Linux driver. I am using Wired connection and it is working fine now