Network Manager will not load at startup

Asked by whenelvisdied on 2011-10-16

I have upgraded to 11.10, and Network manager (nm-applet) will not load on startup. It loads if I run nm-applet from the terminal, but will otherwise not work.

I have an entry in "startup applications..." for network manager that is checked on. I also have edited NetworkManager.conf such that "managed=true".

It seems like there may be some other program suppressing the starting of nm-applet.

When I load nm-applet from terminal, I get the following output, which I suppose could be relevant:

nm-appletwhenelvisdied@Harvey:~$ nm-applet
** Message: applet now removed from the notification area
** (nm-applet:3644): DEBUG: old state indicates that this was not a disconnect 0

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
whenelvisdied
Solved:
2011-10-17
Last query:
2011-10-17
Last reply:
2011-10-16

if you run:

ps -ef | grep nm

is network manager running?

whenelvisdied (whenelvisdied) said : #2

No--here's the output I get:

1000 2117 1839 0 15:12 pts/0 00:00:00 grep --color=auto nm

I suggest you install wicd, uninstall network manager and reboot, should help

whenelvisdied (whenelvisdied) said : #4

I've tried Wicd, which also did not work (though I'm not sure for what reason).

Interestingly, to solve another problem, I created a new user, and when I logged in as that user, network-manager seemed to be working fine. Now I'm back as my original user, and network manager seems to be working, though I'm not sure for how long. I'm going to shut down and see if it appears on restart.

whenelvisdied (whenelvisdied) said : #5

okay....so far, so good. I shut down, booted back up and I have Network Manager. I guess I can mark this solved, though i have no idea why.... If it comes back, I suppose I will too!