network manager not showing

Asked by doug de vos on 2011-02-08

my network manager (ubuntu 10.10) is not showing in system menus, nor showing up in a file search; but you plug a b/b dongle in & it auto connects. Great! but I need to see what connections I have & so modify or add to etc etc ???

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-02-08
Last query:
2011-02-08
Last reply:
2011-02-08

Right-click on your top panel where you want the network manager applet icon to appear, click "Add to Panel...", find "Notification Area" in the list and click on it, then click Add. If that doesn't work, please post again.

doug de vos (dougdevos) said : #2

thanks, tried that but no joy. further: have found nm icon in startup menu & dragged it to toolbar' on clicking it error box comes up "failed to execute child process "nm-applet-sm-disable" (no such file or directory)". Does this command need replacing? what command?? regards doug

doug de vos (dougdevos) said : #3

ps: I am on the pc with the problem writing to you! I have ubuntu10.10 on my asus netbook: no probs!!!

Did it say "nm-applet-sm-disable" (which would indicate a bug), or did it say "nm-applet --sm-disable" (which would indicate that you don't have the Network Manager applet installed)?

doug de vos (dougdevos) said : #5

Failed to execute child process "nm-applet-sm-disable" (No such file or directory)

as copied & pasted

Interesting...

Go to System > Preferences > Startup Applications, select Network Manager (in the Startup Programs list), and click the Edit button. As you've said, the text for "Command" currently is:

nm-applet-sm-disable

Change that text so that it instead says:

nm-applet --sm-disable

(That is, the middle dash is preceded by a space, and doubled.)

Then click Save, and click Close, and log out. When you log back in, the problem should be fixed. If not, please post again.

doug de vos (dougdevos) said : #7

Thanks Eliah Kagan, that solved my question.

doug de vos (dougdevos) said : #8

excellent. Thanks. all is ok.