Can not ping from Ubuntu Maverick

Asked by Kino Velez on 2010-10-17

HP DV5 Running Ubuntu 10.10 64 Bit OS

Since upgrade from Lucid to Maverick I can not ping router 192.168.2.1, Router shows I am connected. I can not even ping my own machine .104 . I am trying to ping router so I can troubleshoot why Remote Desktop is no longer working. This was not a problem with version 10.04.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager-applet Edit question
Assignee:
No assignee Edit question
Solved by:
Kino Velez
Solved:
2010-10-20
Last query:
2010-10-20
Last reply:
2010-10-20
François Tissandier (baloo) said : #1

Just to make sure I understand the problem:

-you can't ping your own routeur
-you can't even ping the IP of your Ubuntu
-but you have internet access?

Kino Velez (kvelez) said : #2

Correct on all three. I have windows computers connected to the same router which have no problem pinging each other or RDP in bet ween them. Only problem is from Ubuntu Maverick machine. Never experienced this problem with Lucid.

François Tissandier (baloo) said : #3

If you are not using a proxy, I would say it's a firewall problem. But you would know if you installed a firewall right ?

Could you type "route" in a terminal and copy paste the output here ?

Kino Velez (kvelez) said : #4

kino@kino-UBNTLap:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
172.16.196.0 * 255.255.255.0 U 0 0 0 vmnet1
192.168.2.0 * 255.255.255.0 U 2 0 0 wlan0
192.168.198.0 * 255.255.255.0 U 0 0 0 vmnet8
link-local * 255.255.0.0 U 1000 0 0 wlan0
default 192.168.2.1 0.0.0.0 UG 0 0 0 wlan0

I just realized I can ping from terminal what does not work is pinging from network tools which I prefer because it lets me choose how many times to ping. RDP still does not work and I really need RDP. I am considering rolling back to 10.04 as I never had this issue and RDP worked flawlessly. Any idea why the inconsistency.

François Tissandier (baloo) said : #5

Interesting, there is a bug in the network tool apparently!
I reported it there:

https://bugs.edge.launchpad.net/ubuntu/+source/gnome-nettool/+bug/663014

Try this:

ping -b -c 5 -n www.yahoo.fr
It will ping it 5 times only in the terminal.

François Tissandier (baloo) said : #6

Then for RDP...
If you are using the usual port, can you try this in the terminal:

telnet IP_ADRESS_OF_YOUR_SERVER 3389

Thanks !

Kino Velez (kvelez) said : #7

I am glad I was not the only one having problems with Network Tools.

Your suggestion worked but how do I get the RDP GUI working?

This is what I get

kino@kino-UBNTLap:~$ telnet 192.168.2.101 3389
Trying 192.168.2.101...
Connected to 192.168.2.101.
Escape character is '^]'.
Connection closed by foreign host.

François Tissandier (baloo) said : #8

The telnet seems OK, it can connect on the RDP port. So I'm surprised that the RDP GUI is not working. I checked mine, it's working fine

-Could you confirm the settings you are using ?
-When you try to connect, what error message do you get ?

Thx !

Kino Velez (kvelez) said : #9

I get no errors, it just does not connect. Similar to what i was experiencing with Network Tools. I am using the same settings I had from 10.04. What I am calling RDP is GnomeRDP. Are you using the same app?

François Tissandier (baloo) said : #10

Installing it now, I keep you updated

François Tissandier (baloo) said : #11

It's working here, connecting to a Windows 2003 server.
would you mind showing me all the settings of your connection?

Also, maybe we could have more info if you run GnomeRDP from the terminal. Open one, type gnome-rdp, enter, and try a connection? Worth a try...

Kino Velez (kvelez) said : #12

Here are my settings
New Session. All the saved ones were erased when 10.10 was installed.
server 192.168.2.101
Protocol RDP
Profile RDP8 = RDP Version 5 Bpp24 800 X 600
Identity \Kino
Click OK and screen resets back to start with no sessions saved. Running from terminal did not make any difference.

Kino Velez (kvelez) said : #13

Just about the time I was ready to roll back this is what I discovered. There is a bug or an "undocumented feature" in GnomeRDP that no longer shows the session saved. When you open gnome RDP and try to establish a connection the RDP GUI doe nothing, however an icon is placed on the panel on top something it always did. If you click on the icon it shows nothing. If you RIGHT click on the icon it shows the list of saved sessions. If you select one session from the RIGHT click list it then displays the GUI and lets you connect. The problem exist but there is a work around. This ticket can be closed if you agree.

François Tissandier (baloo) said : #14

You opened it, so feel free to close if if you have a solution :)

You can also try Remmina, it's the RDP client I'm using, I find it quite features complete and reliable to use !

Kino Velez (kvelez) said : #15

Thanks I tried Remmina but Gnome RDP works better for me.