Netbook upgrade to 10.10 desktop is only wallpaper, no menus/taskbars

Asked by Brett Monroe

Ubuntu 10.04 installed on Dell Mini 10v; upgrade to 10.10 went smoothly; rebooted and logged in, desktop displays new wallpaper - that's it. No other gui functionality exists.

I can toggle into cli and log in that way.

I can login via the UNE 2D option and as the normal ubuntu desktop option just fine. Just not with the new UNE/unity environment.

Any idea what I need to do to reset/repair the new UNE environment to make it functional?

Question information

English Edit question
Ubuntu netbook-meta Edit question
No assignee Edit question
Solved by:
Brett Monroe
Last query:
Last reply:
Revision history for this message
Corey B. (cbodendein) said :

Unity, the new interface in Ubuntu Netbook 10.10, requires 3D acceleration. It is likely that you don't have 3D acceleration on your netbook, so you can't use Unity.

Revision history for this message
Brett Monroe (brettmonroe2001) said :

Good evening. The Dell Inspiron Mini 10v (1011) has an Intel Mobile 945Gm/GMS/GME 943/940GML Express Integrated Graphics Controller.

I believe it is capable of supporting 3D and from what I have read online, and generated from my own system that the output below appears to show that it is supporting 3D. However I am not sure what to make of the line below, "DRI2SwapComplete: bad drawable."


glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20100330 x86/MMX/SSE2

egrep "(GLX|DRI)" /var/log/Xorg.0.log
[ 22.863] (==) AIGLX enabled
[ 22.863] (II) Loading extension GLX
[ 22.866] (II) Loading extension XFree86-DRI
[ 22.867] (II) Loading extension DRI2
[ 22.997] (II) intel(0): [DRI2] Setup complete
[ 22.997] (II) intel(0): [DRI2] DRI driver: i915
[ 23.047] (II) intel(0): direct rendering: DRI2 Enabled
[ 23.102] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 23.102] (II) AIGLX: enabled GLX_INTEL_swap_event
[ 23.102] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[ 23.102] (II) AIGLX: enabled GLX_SGI_make_current_read
[ 23.102] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[ 23.102] (II) AIGLX: Loaded and initialized /usr/lib/dri/
[ 23.102] (II) GLX: Initialized DRI2 GL provider for screen 0
[ 333.492] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[ 349.331] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[ 351.861] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[ 359.599] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[ 557.742] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable
[ 675.284] (EE) intel(0): [DRI2] DRI2SwapComplete: bad drawable

Revision history for this message
Brett Monroe (brettmonroe2001) said :

Hello - I tried two things to see if either would shed light on my issue.

1) I created a new user account to see if my profile was corrupted in some fashion - however that account also failed to exhibit anything other than wallpaper when I logged into the unity environment.

2) I installed the 10.10 remix on a flash drive and booted off it just fine - the unity view works fine on my hardware - it must just have botched during the upgrade from 10.04. At this point it looks like my option is to back up my content and reinstalled if I want to make use of the unity environment.