How do you get Java JDK and Netbeans to work on Ubuntu 11.04

Asked by Heath on 2011-11-09

I downloaded JDK 6 Update 29 with NetBeans 7.0.1.(cobundle). I Downloaded the installer file and saved it on my system.
When I double clicked on installer file:

Could not open the file /home/tool/Downloads/jdk-6u29-nb-7_0_1-linux-ml.sh.
gedit has not been able to detect the character encoding.
Please check that you are not trying to open a binary file.
Select a character encoding from the menu and try again

The instructions below are from www,java,com..I am confused with "navigate to the directory
Navigate to the directory into which you downloaded the installer file and type:
chmod +x <installer-file-name> to change the installer file's permissions so it can be executed.
Installing the Software
1. Type the following command from the directory where you placed the installation file:
./<installer-file-name>
2. At the Welcome page of the installation wizard, click Next.
3. At the JUnit License Agreement page, decide if you want to install JUnit and click the appropriate option, click Next.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu netbeans Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-11-09
Last query:
2011-11-09
Last reply:
2011-11-09

Suppose you had downloaded the file to your Downloads folder.

Then open a Terminal window (Ctrl+Alt+T) and run these commands:

cd ~/Downloads
chmod +x jdk-6u29-nb-7_0_1-linux-ml.sh
sudo ./jdk-6u29-nb-7_0_1-linux-ml.sh

Heath (heathbaz) said : #2

Thanks Eliah Kagan, that solved my question.