cannot connect to wireless network

Asked by simon on 2009-09-24

I cannot connect to my wireless network i just installed Ubuntu on my HP mini 1030nr it says device not ready and this netbook dose not have a Ethernet port to plug into so HELP!!!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Solved by:
Randall Ross
Solved:
2009-09-24
Last query:
2009-09-24
Last reply:
2009-09-24

If you don't know your own network password, then nobody here can help you... well... at least we're not going to tell you how to crack into a WiFi network...

simon (excaliburorama) said : #2

Thanks for that. I think it might be a bug, because when I go through a list of passwords nothing happens. There are several passwords on the back of my wireless hub a wireless key an admin password and a wireless key. Which one do I use?

jari (jaript) said : #3

If it asks for password for "default keyring", that's not the network password but the one for your keyring. Which would normally be the same as your login password, but if you changed your login password the keyring password doesn't change. You can change it with the Passwords and Encryption Keys application (seahorse) -- if it's the same as your login password you won't be asked for it.

simon (excaliburorama) said : #4

I have just called British Telecom and they tell me that Linux is not compatible with BTHomeHub. Is this true? I actually did manage to access the network about a day ago, and "AutoBTHomeHub" is listed under "configure VPN" "Wireless". I cannot however repeat this action.

Best Randall Ross (randall) said : #5

Please allow me to provide some general guidance that might help steer you through some of this. This is not a how-to, but perhaps it will get more discussion going and get you closer to a positive outcome.

In my explanation below, BTHomeHub = router, so substitute that term.

Many Internet "Service" Providers will say the sentence: "Linux is not compatible with <insert ISP service name here>". Unfortunately, that is misinformation.

When you hear them say it, it can mean one (or more) of the following:
1) The support and service personnel we hire do not have Linux expertiseanswer)
2) We do not value your right to choose an operating system
3) We have proprietary software that we use to manage (change,view) your router (or that we let you use), and that software does not run on Linux
4) We don't understand Linux, and don't want to invest in learning it,
5) We do not understand that networking is based on standards (TCP/IP, DNS, ARP, HTTP, etc.) that are independent of operating system.

Here are some workarounds:
a) Most routers can be managed from a web browser. Browser software runs on all platforms. Try using your web browser to change your router settings. (You'll need to know the inside IP address of your router, usually something like 192.168.1.1, and you will need to connect to it using an ethernet cable).
b) Change to an ISP that is "Linux-friendly" if they continue to be unhelpful.

About your passwords. There are a few to be aware of:
i) Your router admin password. This is the password that is stored on the router and that lets you change its settings using a web browser.
ii) Your keyring password. This is the "master password" that Ubuntu uses to access keys and other passwords needed to log into applications/services. It is normally the same as your Ubuntu login password, unless you changed it.
iii)Your wireless password. This is the password (or passcode) used to log into a wireless network that has enabled WPA or WEP.

simon (excaliburorama) said : #6

Thanks for that Randall. I just connected my computer to my router using an
ethernet cable
a message came up saying "Auto eth0 connection established" and I didn't
even have to enter the IP address of my router.......The crucial thing is,
not to panic. I don't know which of the reasons you gave for them saying
Linux and BT are not compatible is the correct one perhaps all of them, I
suspect...
On Thu, Sep 24, 2009 at 10:04 PM, Randall Ross (rrnwexec) <
<email address hidden>> wrote:

> Your question #83674 on ndiswrapper in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ndiswrapper/+question/83674
>
> Status: Open => Answered
>
> Randall Ross (rrnwexec) proposed the following answer:
> Please allow me to provide some general guidance that might help steer
> you through some of this. This is not a how-to, but perhaps it will get
> more discussion going and get you closer to a positive outcome.
>
> In my explanation below, BTHomeHub = router, so substitute that term.
>
> Many Internet "Service" Providers will say the sentence: "Linux is not
> compatible with <insert ISP service name here>". Unfortunately, that is
> misinformation.
>
> When you hear them say it, it can mean one (or more) of the following:
> 1) The support and service personnel we hire do not have Linux
> expertiseanswer)
> 2) We do not value your right to choose an operating system
> 3) We have proprietary software that we use to manage (change,view) your
> router (or that we let you use), and that software does not run on Linux
> 4) We don't understand Linux, and don't want to invest in learning it,
> 5) We do not understand that networking is based on standards (TCP/IP, DNS,
> ARP, HTTP, etc.) that are independent of operating system.
>
> Here are some workarounds:
> a) Most routers can be managed from a web browser. Browser software runs on
> all platforms. Try using your web browser to change your router settings.
> (You'll need to know the inside IP address of your router, usually something
> like 192.168.1.1, and you will need to connect to it using an ethernet
> cable).
> b) Change to an ISP that is "Linux-friendly" if they continue to be
> unhelpful.
>
> About your passwords. There are a few to be aware of:
> i) Your router admin password. This is the password that is stored on the
> router and that lets you change its settings using a web browser.
> ii) Your keyring password. This is the "master password" that Ubuntu uses
> to access keys and other passwords needed to log into applications/services.
> It is normally the same as your Ubuntu login password, unless you changed
> it.
> iii)Your wireless password. This is the password (or passcode) used to log
> into a wireless network that has enabled WPA or WEP.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/ndiswrapper/+question/83674/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/ndiswrapper/+question/83674
>
> You received this question notification because you are a direct
> subscriber of the question.
>

simon (excaliburorama) said : #7

hanks for that Randall. I just connected my computer to my router using an ethernet cable
a message came up saying "Auto eth0 connection established" and I didn't even have to enter the IP address of my router.......The crucial thing is, not to panic. I don't know which of the reasons you gave for them saying Linux and BT are not compatible is the correct one, perhaps all of them, I suspect..