ndiswrapper doesn't function

Asked by Chris Kjellqvist on 2013-01-12

Hi,
     I just got a clean install of Ubuntu 12.04 on my computer, plugged in my network adapter, got ndiswrapper (only ndiswrapper, not utils or anything), downloaded the drivers for it, installed the drivers, aaand.... it doesn't work. I've done the whole routine everyone says with the iwconfig, restart network manager, etc... but nothing has worked. I've even blacklisted things that have been said to keep it back, but still nothing. So if someone could help me with this, that would be greatly appreciated.

More information: It's a Belkin N300, I think. But more importantly, it's id is 050d:6050. My operating system is 64-bit. Also, I'd appreciate the minimal amount of downloads since my internet connection is limited to my tablet, making it difficult to get files onto the computer, but while I can still download things, I don't really want to be downloading a whole bunch of programs like ndisgtk or things like that. Also I would avoid wireless, but I'm on a second floor while the router is on the first floor, so ethernet is not an option.

So if you can help, that would be great, Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-12
Last reply:
2013-03-12

This question was reopened

If you run:

sudo modprobe ndiswrapper

Does it work ok?

Thanks actionparsnip, that solved my question.

yup

sorry about that, clicked the wrong button... but yah sudo modprobe ndiswrapper works just fine

Run:

echo "ndiswrapper" | sudo -a /etc/modules > /dev/null

In future I suggest you buy super compatible devices

it keeps showing up as a usage error....

I type it in one command? And with the quotation marks?

It adds the module to the modules to load at boot, try a reboot

I don't think it did anything, but I rebooted.

In another thread I posted, I was told to type sudo modprobe -v ndiswrapper. Now that I can find the networks, I cant connect to them..

tony (runner7171-o) said : #11

 sudo modprobe ndiswrapper

FATAL: Module ndiswrapper not found.

Can you help with this problem?

Provide an answer of your own, or ask Chris Kjellqvist for more information if necessary.

To post a message you must log in.