Help with D-link DWA-130

Asked by Richard Cox on 2007-12-18

Problems:

1) Windows Driver provided does not include .sys or .inf files to use with ndiswrapper

2) Linux does not seem to recognize usb adapter when plugged in.

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Solved by:
C de-Avillez
Solved:
2007-12-20
Last query:
2007-12-20
Last reply:
2007-12-20
C de-Avillez (hggdh2) said : #1

I am sorry, but I could not find any reference to WPA-130 in www.dlink.com. Can you please verify the product name?

Richard Cox (rcox) said : #2

Sorry - DWA-130

I have the unit working well under windows XP, but I can't even seem to get Gutsy to recognize the adapter when plugged in.

C de-Avillez (hggdh2) said : #3

Thanks.

First we have to find out more about this adapter.

0. if it is already plugged in, take the adapter out. Wait some 10 seconds.
1. insert the adapter; wait some 10 seconds (really, not needed, but lets give the system some time to see it).
2. on a terminal, run 'dmesg|less'; at the end of the output you should see some messages showing the adapter being recognised. Copy them here.
3. run 'sudo lsusb -v' from a terminal, and paste here the output for your adapter (at least right now we do not need any other but this adapter).

Meanwhile I am downloading the D-Link drivers, and will have a look at them.

Oh, BTW -- I hope you are not running Linux 64bits -- DLink does not seem to provide drivers for it.

C de-Avillez (hggdh2) said : #4

OK, a bit more of data I found. The D-Link provides the installation packaged with InstallShield. As such, cabextract will not work. You will need something like unshield (available from Ubuntu), or, on Windows, something like zipscan.

The *.sys and *.inf will then be available for you to use.

Richard Cox (rcox) said : #5

Ok on the software side. unshield failed to open the CAB files (aborted). However, as I have the adapter working in Windows, I was able to locate the .sys file (mrvw245.sys). However, I could not locate a matching .inf file! (including hidden directories& files)

I searched for all the .inf files on my windows install, to look for anything that resembled the name of the .sys file, or d-link or DWA-130 and could not find a match.

I am running 32-bit ubuntu.

On the hardware side, lsusb -v included the adapter, so it looks like Gutsy can see the adapter, it just doesn't "visually" react to its presence.

I've looked over on the ndiswrapper site to get an idea. I am trying down loading other drivers that use the same chipset to see if there are other drivers that have .sys and .inf files that I can use.

I will get back you with that.

Best C de-Avillez (hggdh2) said : #6

The inf file is named 'netmw245.inf'. It should be under \Windows\inf. I am sorry, but due to potential copyright issues I cannot give it to you.

Richard Cox (rcox) said : #7

Yes, that should be the name. However, it is not in the windows\inf folder.

C de-Avillez (hggdh2) said : #8

please email me: hggdh2 at gmail dot com

Richard Cox (rcox) said : #9

All set - problem resolved.

Thanks again for great help

Richard Cox (rcox) said : #10

Thanks hggdh, that solved my question.

Safirr (safirr) said : #11

I have the same problem, can you email me the file too at safirr at gmail dot com
Thanks in advance

burkemc (mcburke38) said : #12

Richard Cox,
   Did you get the DWA-130 working with Ubuntu?? I'm having problems. Could you help?

OrneSpike (ornespike) said : #13

When I use the driver that was on the cd it loads into ndiswrapper fine but on reboot it hangs at OpenBSD server while its booting up.

heislord5 (heislord5) said : #14

hmmm.

Help. I can't find the netmw245.inf file anywhere on the internet. If found one for a different card and realized it wouldn't work with the dwa-130. I need the dwa-130 inf file

Any who can help, great!

<email address hidden>

meka4996 (meka4996) said : #15

Wireless Connection= Dlink DWA 130 ... N usb adapter
This tutorial is proven in Ubuntu 7.04 Feisty.
Go to...
https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper
Scoll down and see "2.2. Installing Packages (With Internet access on another computer)"
Download the following deb files, put them together with the adapter inf file(from adapter CD) on a usb drive,
Plug the adapter in, start the computer with Ubuntu in LiveCD mode.
After booting up, go to
MainMenu-> Accessories -> Terminal, install the deb files in this order:

  sudo dpkg -i ndiswrapper-common_*.deb

  sudo dpkg -i ndiswrapper-utils*.deb

  sudo dpkg -i --force-depends ndisgtk_*.deb

#Note: Ubuntu don’t suggest su

Installing Windows driver by using ndisgtk: Go to MainMenu -> System -> Administration -> Windows wireless drivers

Click on "install new driver" -> select the adapter inf file in the usb drive.

Then even it shows: "Hardware present: No", ignore it.

Go to ConfigureNetwork, click on WirelessConnection, click on Properties, untick EnableRoamingMode, choose NetworkName and key ,

enter the password, use DHCP, leave the rest blank.

then see if the device is flashing, if not, unplug then plug it in again...
if still not working, restart the computer and do it again ...

when seeing flashing, then check the internet... yeah, we're in!!!

#Note: even after all of the above and after installing Ubuntu on my hard drive, and after many many successful internet connection, sometimes(only occasionally, so it is ok), it still won't work. (especially if the device won't flash during boot or the boot process freezes...)
In that case, just unplug the device, then restart the computer, after the boot menu, plug in the device again(for re-detection), it will work this way always =)

nonsense (absolut-nonsense) said : #16

Ok,
I'll add my 5 cents :)
In case you don't have your drivers CD or you can't find it do the following:
download official D-Link driver for XP from:
ftp://ftp.dlink.com/Wireless/dwa130/Drivers/dwa130_drivers_130.zip
unpack it
There only one file "Setup.exe". You can't unshield it, so use wine to run it.
click next until you prompted to connect device then abort.
run ndisgtk (from command line with sudo)
the inf file in :
<current user homedir>/.wine/drive_c/windows/usbdevice/
enjoy your DWA-130

grondinm (marcg666) said : #17

Time for my 5cents

using the steps posted by meka4996 i was able to get it to work with a few modifications to his steps. First off i am using a 64-bit system. i went to the d-link site and downloaded the 64-bit xp drivers. did the steps he posted but this is what i had to do differently in order for it to work.

"Click on "install new driver" -> select the adapter inf file in the usb drive."

this work no problem

then when i tired to do this

"Go to ConfigureNetwork, click on WirelessConnection, click on Properties, untick EnableRoamingMode, choose NetworkName and key ,"

the properties button could not be clicked nore could i click on unlock. so i went to

MainMenu -> System -> Administration ->networks

then i was able to click on unlock and configure the network

after a reboot everything works fine so far. even between subsequent reboots. thanx for your help.

robo100 (robertnatal) said : #18

grondinm,
Really? I cannot find 64 bit drivers for the dwa-130 anyplace. Dlink sent me an email stating that they have not written any 64 bit drivers for this product. The only USB product they have that has 64 bit drivers is the WUA-1340 which is a wireless G adapter and the 64 bit drivers are only for Vista. If you have a 64 bit driver where did it come from? Do you have a link?

I am having the same problems everybody else is having. I am running Ubuntu 8.04 (64 bit AMD) and I can load the driver using ndiswrapper and it sees the dlink usb device but it does not come up in the network configuration.

nonsense (absolut-nonsense) said : #19

 robo100,
Most probably, you can use 32bit drivers on 64bit system.
I did it once with LightScribe drivers.

I'll try it on my Gentoo system (Ubuntu become total junk. worse then windows) and post my results

robo100 (robertnatal) said : #20

Ok,
I found out some more information. There are 64 bit drivers but only for revision B and Revision C of the dwa-130. I happen to have revision A which does not have 64 bit drivers.

WillieHa (ha-willie) said : #21

same with me, I have the revision A version here, can someone please send me a copy of the .inf and .sys files? My address is
<email address hidden>
thank you

meka4996 (meka4996) said : #22

Hi guy, thanks for the comments.
Please do yourself a favor, get the Ultimate Edition 2.0, a Ubuntu 8.10 based distro
then run LiveCD...
Ndiswrapper is already loaded (not sure if it's same for Ubuntu 8.10)
Go to System-> Admin -> Windows Wireless Drivers
Click on InstallNewDriver, select .inf file (not sure about .sys file)
Check HardwarePresent= Yes
Click on ConfilureNetwork...
If it says "Could not find a network configuration tool", that is ok.
Go to your Desktop, on the top right, right click on the Networking icon, select "Enable Network"
Select your wireless network or any other networks you may have... Have fun =)

meka4996 (meka4996) said : #23

Use Ndiswrapper AFTER unloading other wireless drivers!!!
Ubuntu 7.04, Dlink wireless adapter DWA 130
After changing the wireless network name and password two times, somehow my Ubuntu 7.04 kept trying to connect to the wireless network for a long time, the whole pc became very slow, even keyboard was not responding, it seemed like two drivers[ndiswrapper and a native linux driver from updates] tried to control one dlink dwa 130 wireless adapter, then after forcefully restart the pc a few times, I could not start the GUI anymore... error messages: "failed to start X server. X server disabled. Restart GDM when it is configured correctly... nm_hal_d... var/log/Xorg.0.org ... using config file /etc/X11/Xorg.conf..., failed to load module fglrx, module does not exist... No drivers available...
Fatal Server Error..."

eventually, I reinstalled Ubuntu.
So make sure you disable all other wireless drivers...
references: https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

--Display list of modules
$ lsmod ...lists currently loaded kernel modules
$ lsmod | grep ndis ... list only one driver "ndis*"

--Blacklist other modules
$ sudo gedit /etc/modprobe.d/blacklist
$ sudo kate /etc/modprobe.d/blacklist (for Kubuntu)
Adding similar lines below for all wireless related modules at the end of this file
[Make sure neither the Ubuntu, nor the RaLink modules are loaded (the former doesn't work, while the latter causes conflicts]. If you are using ndiswrapper, you do NOT want any Ralink rtxx modules!!
blacklist rt2400
blacklist rt2570
...
blacklist bcm43xx

... the modules usbcore and ohci_hcd are standard because
$ lsmod | grep ndis
ndiswrapper 192920 0
usbcore 146028 3 ndiswrapper,ohci_hcd

reboot, if the module is still being loaded...
...make sure another module does not depend on this module
$ modprobe --show-depends moduleName (it will list itself there too)
or rename module dependencies so it won't load...
$ cd /lib/modules/`uname -r`/ubuntu/wireless/rt2x00
$ sudo mv rt2500usb.ko rt2500usb.ko_bak ...manually rename rt2570 module dependencies

meka4996 - thank you so much for this post! I am a newbie to Ubuntu 8.10 and because of your advice, I finally connected to our wireless network. That completely made my day and I wanted to let you know I really appreciated your advice!!