Netgear WG111 connection issue

Asked by NF24 on 2007-12-15

I am having trouble with the Netgear WG111 wireless adapter on a dual-boot Windows XP/Ubuntu computer. The adapter works fine in Windows As many of you probably know it is notoriously hard to install in Ubuntu but it can be done. I successfully installed the driver with ndiswrapper, and ndiswrapper -l shows the adapter. Now Netgear's website claims that my adapter is a v1 (serial number starts with "130"), but the usb id is 0846:4240 which is a v2. That aside, I went ahead and configured the network. The problem is that the adapter refuses to connect to the router. My router (Netgear WGR614v6)'s DHCP function does not work for some reason so I have to manually assign an IP address. So, basically, my question(s) are:
*Why won't my adapter connect to the network?
and
*If I need to manually assign IP addresses, do I assign a separate one to Windows and Ubuntu, even if they are on the same computer and use the same adapter?

Thanks in advance to whomever responds.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Last query:
2007-12-16
Last reply:
2007-12-17
NF24 (whammy11) said : #1

It seems to be a problem with either the WG111 or the router. I have contacted Netgear support. Still open to any suggestions.

Pete Higgins (petehiggins) said : #2

I installed a Netgear WG111UNAR 108 Mbps USB adapter, but I had to use both of its Windows drivers (athfmwdl.inf & wg111u.inf) that I installed with ndisgtk.

I don’t know if it will help, but take a look at post #19189.

Installing the drivers and configuring the adapter with ndisk worked with my Netgear WGT624 V2 Router, but not my Airlink router. When I installed the drivers with ndisk and then configured the adapter with Network Manager the adapter worked with both routers.

Can you help with this problem?

Provide an answer of your own, or ask NF24 for more information if necessary.

To post a message you must log in.