No Wifi authentication with 10.10 + Acer revo 3700

Asked by Vivith on 2011-01-12

Update to the below problem:

I trolled through many comments by other users in the launchpad and it appears to me that the commad
"sudo modprobe rt3090sta" fixes the problem.
However, I need to execute this and I need to connect to the network by selecting the network in the nerwork manager icon, everytime I boot my PC. Can you please suggest me any permanent fix for this one or do I need to correct it via a startup script?
Also, my boot and shutdown splash screens have been smeared by some nasty warning/error message by ndiswrapper after enabled the HW using ndiswrapper.
Thank you very much for the support offered.

***********************************************************************************************************************************************
I've a problem with my WiFi connection on Acer Revo 3700 currently running with 10.10 (64 bit).
The WiFi hardware did not work out of box with 10.10, hence I used ndiswrapper to install the drivers.
Now the computer identifies and lists all the available local wireless networks, but does not connect to any of them.
I tried my secure network by giving the password. The computer tries to connect and fails after sometimes.
I also tried to connect an unsecured network, but computer failed again.

I also tried to manually reconfigure by setting the IP address (192.168.0.3 - as 192.168.0.2 is being used by my laptop) and subnet mask as 255.255.255.0 ( I found this configuration on my other laptop), but it does not solve the problem

I think the wireless need not be configured as it is plug-and-play, isn't it?
I can not connect the computer to the router via ethernet port (wired connection) as my router sits in other room :(
Can any one please help me?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Last query:
2011-01-12
Last reply:
2011-01-16

Can you give the output of:

sudo lshw -C network

Thanks

ok then run:

sudo -i
echo "rt3090sta" >> /etc/modules
exit

The module will now be loaded at boot

Can you help with this problem?

Provide an answer of your own, or ask Vivith for more information if necessary.

To post a message you must log in.