Installing ndiswrapper-1.48 so I can install driver for wireless card.

Asked by Leroy Wolins on 2007-09-22

I am trying to install a wireless pci adapter, EDIMAX EW-7128g. I have successfully downloaded ndiswrapper-1.48, and copied the driver, rt61.inf, to the desktop. It seems I need ndisgtk to install ndiswrapper so I can use ndiswrapper to install rt61.inf -- but I can't find ndisgtk?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ndiswrapper Edit question
Assignee:
No assignee Edit question
Solved by:
Leroy Wolins
Solved:
2007-09-23
Last query:
2007-09-23
Last reply:
2007-09-23
Wrwrwr (wrwrwr) said : #1

Hardware compatibility list told me that your card should works without ndiswrapper. But you probably know better what you want.

This should install driver under ndiswrapper:
sudo ndiswrapper -i ~/Desktop/rt61.inf

To just get ndisgtk (you have to install the compiled driver to make ndisgtk use it, otherwise it will automatically install older one):
sudo apt-get install ndisgtk

Note there are many steps to follow and some pitfalls when trying to use ndiswrapper, if you don't know it already, take a look here:
https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper
https://help.ubuntu.com/community/WifiDocs/

Wrwrwr (wrwrwr) said : #2

Oops forgot to mention you'll also need to compile this new ndiswrapper. Maybe first try to follow this guide from the first link, if this doesn't work or you can already tell you'll need the new version of ndiswrapper let me know.

Leroy Wolins (corlee) said : #3

I've tried lots of things.

Currently, I have on my desktop both the compressed file and the ndiswrapprer1.48 folder. When I open ndiswrapper 1.48 I find a folder and a file with the name "ndiswrapper." the folder is in my user folder, lee, and the other is contained in lee/Desktop/ndiswrapper1.48/utils. The one in lee has a lock on it and can't be moved to the desktop. With this configuration, I issued the command you give above. The response in the terminal indicates ndiswrapper is not installed.

Wrwrwr (wrwrwr) said : #4

If you would go through the ndiswrapper instructions it tells you to install ndisgtk in point 2.1. And that would automatically install ndiswrapper (1.38 probably).

Maybe you uncompressed using "sudo tar ... "? That would explain why it has a lock.
remove the unpacked one:
cd ~/Desktop
sudo rm -r ndiswrapper-1.48

Now extract it to the desktop using archive manager, that is double clicking on the tar.gz.

Don't try to move single files; ndiswrapper requires more of them to function.
This will compile and install your downloaded ndiswrapper:
cd ~/Desktop/ndiswrapper-1.48
make
sudo make install

Then you would do:
sudo ndiswrapper -i ~/Desktop/rt61.inf
(Assuming you have rt61.inf and rt61.sys on desktop.)

Then test it:
ndiswrapper -l
(-l like in list)

If the last gave a positive answer:
sudo ndiswrapper -m

Also, you may have to disable an alternative free driver, if there is one. Basic guide has a command for that, however in your case the driver would probably be "madwifi", not "bcm43xx". "ndiswrapper -l" should tell you about any alternative drivers.

Leroy Wolins (corlee) said : #5

Everything seemed OK until the 'make' command after:
       cd ~/Desktop/ndiswrapper 1.48

After outputting a dozen or so lines and entering '/home ... /utils', a long list of errors is printed out.

The first line preceding the first error is:
       gcc -g -Wall -I../driver -o loaddisdriver.c, and then:
       loaddisdriver.c:15:20,error:stdlib.h: No such file or directory

A probable reason it didn't go OK is that I removed the unpacked file improperly before reading the instructions for removing it properly.
I highlighted it and pressed delete. The locked file is still there.

Wrwrwr (wrwrwr) said : #6

You can right click the file and check on its properties under permissions tab, what the owner of the file is. If it is root you'll have to remove using sudo command.

The make fails because you lack dependencies. Install linux-headers-generic (or server; test with "uname -r" what you need) through synaptic. You may also need gcc and maybe build-essential.

Leroy Wolins (corlee) said : #7

I was able to remove the locked file with a sudo command even though the owner was root. There is another locked file in that directory called Examples.

I downloaded the files you indicated through Synaptic. i downloaded the list of essential packages and determined that all were in the filesystem except sysvinit.

i tried again to use the make command and got identical results to the last two times. I have not used Synaptic to download sysvinit because Synaptic indicated it is necessary to remove several other files if I were to install sysvinit. should I do this?

Wrwrwr (wrwrwr) said : #8

Don't download sysvinit, you don't need it (it's a starting system that has been used in ubuntu some time ago).

Sudo gives you root (administrator) privileges. With the rm -r you removed whole directory recursively.

There are many files on your system owned by root, all critical files (you can see them by going Places-->Computer-->Filesystem). This is done that way so you won't delete anything important by mistake, or so malicious programs can't break your system. Don't delete anything else that way.

You are definitely missing some headers. Sorry for my lack of precision last time, there is a package with exact name "build-essential". This one should also install libc6-dev which provides stdlib.h header.

Leroy Wolins (corlee) said : #9

It worked. The driver is invalid but ndiswrapper did it's job. Now i have two more jobs to do. First, I will get all the commands and procedures together and write-up as precisely as I can what was done. Second, i will try the other drivers on the EDIMAX disk. I appeciate your help. Thank you.

What i did wrong on my third attempt was I failed to remove the unpacked file.

brad waddell (brad-waddell) said : #10

this seems to be the exact problem I am having. Where do I get this "build-essential" package?

Wrwrwr (wrwrwr) said : #11

It's in the main repository. To install use synaptic or adept package manager, or type in a terminal:
sudo apt-get install build-essential

If you need further help create a new question, please.

dale bednell (dalebednell) said : #12

hi, write i have finnaly installed ndiswrapper common what do i do next? can any body tell me please

 Dale

Wrwrwr (wrwrwr) said : #13

Hello,

Please ask a separate question, including at least your wireless card model and the problem you're having; you'll have a much higher chance for a proper answer that way.

As a quick note: probably you'll need ndiswrapper-common, ndiswrapper-utils-1.9 and ndisgtk, all available from repositories, so no compilation should be needed anymore (but you need to download these somehow). Then you disable the free drivers and install the Windows driver through ndisgtk for example (System->Administration->Windows wireless drivers). A detailed how-to is here: https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper .

WR.