NCURSES not found while compiling VLC

Asked by balagopalan gundeboiana on 2012-09-13

Hi,
      Iam trying to compile latest VLC on my ubuntu machine using the help of http://wiki.videolan.org/UnixCompile.
NCURSES is installed in my machine, also when i try to do a apt-get it says newer version is already available

but when i do ./configure in my vlc folder.i get following error.

checking libtar.h presence... yes
checking for libtar.h... yes
checking for NCURSES... no
configure: error: Package tinfo was not found in the pkg-config search path.
Perhaps you should add the directory containing `tinfo.pc'
to the PKG_CONFIG_PATH environment variable
Package 'tinfo', required by 'ncursesw', not found.

any help is greatly appreciated.

regards,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ncurses Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-09-17
Last query:
2012-09-17
Last reply:
2012-09-14

This question was originally filed as bug #1050341.

Jason Conti (jconti) said : #1

This really appears to be more of a question than a bug report, so I am going to convert it into a question.

Looking at the output from configure, it appears that you need to install the package: libtinfo-dev

If you scroll down a bit in http://wiki.videolan.org/UnixCompile under the heading "The preferred method", there is a command:

sudo apt-get build-dep vlc

Which if you have the source repositories enabled (in software-properties-gtk make sure the Source Code box is ticked) should get you most of the libraries required to compile VLC.

Hope that helps.

Can you give the output of:

lsb_release -a; uname -a

Thanks

Hi jason Conti,
                            I have used the sudo apt-get build-dep vlc command to get all dependencies, but the problem is ncurses library is not getting detected in spite of being present on the system, i tried installing ncurses5.9 library manually still im getting same error.

thanks,

Hi actionparsnip, please find the output of lsb_release -a; uname -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux balagopal-VirtualBox 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux

Thanks

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

Will give you 2.0.3

Jason Conti (jconti) said : #6

Oh, seems there actually might be a bug here, I found: https://bugs.launchpad.net/ubuntu/+source/ncurses/+bug/900635

It seems that tinfo.pc wasn't being provided by libtinfo-dev in oneiric. However the package was just updated in oneiric-proposed which should fix your bug. Please see https://wiki.ubuntu.com/Testing/EnableProposed if you would like to try and see if it fixes your build.

Thanks should go to actionparsnip, I never would have noticed the bug without his requested additional info. Apologies for converting to a question prematurely.

I reinstalled latest ubuntu release(Ubuntu 12.04.1 LTS) in my machine and the problem is fixed now.

Thanks for all your help.

regards,
Bala

Thanks actionparsnip, that solved my question.