Fail to install Java 6.0.17 for Mozilla Firefox 3.5.7 in Ubuntu 9.1

Asked by springtime on 2010-01-18

OS: Ubuntu 9.1
Java: Ver 6.0_17
Mozilla Firefox 3.5.7

I followed the instructions as per the Java official site. Though Mozilla firefox showed the option to enable Javascript and Java, but the charts from www.fxcm.com which requires Java indicates that either not installed properly or enabled.

Help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
springtime
Solved:
2010-01-19
Last query:
2010-01-19
Last reply:
2010-01-19
pererik87 (pererik87) said : #1

I installed the restricted extras package in Software center and i can see the charts. applications -> software center -> search ubuntu restricted and install

springtime (limlim88) said : #2

Thanks for yr quick response. The http://www.fxcm.com/forex-charts.jsp only display image charts. When I try to go into the live chart by clicking on "Access Live Currency Chart" in Powerchart option, the live charting do not appear.

wojox (wojox) said : #3

Install java from the terminal:

sudo apt-get install sun-java6-jre sun-java6-plugin

springtime (limlim88) said : #4

Hi Wojox,

I installed the Jave using your command line as above, but when I try to go into the live chart, the error message was either the Java was not installed properly or not activated in the browser. I checked the Mozilla--Edit, Preference, Content and it showed enabled.

Do I need to delete the earlier Java installation I did using the SUN Java instruction sheet? By the way, there are also three folder locations of the browers, one as Mozilla, another Firefox and and Firefox 3.5.7 What else can I do to activate the Live Chart?

Can you give the output of:

uname -a

I can advise how to install using the .bin file.

springtime (limlim88) said : #6

First of all, I would like to thank you all for the kind and persistent support to my Java installation.

artlim66@artlim66-desktop:~$ uname -a
Linux artlim66-desktop 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

By the way, I tried installing the .bin file as adviced by SUN Java official site. When it comes to the installation for the following command---

ln -s /usr/java/jre1.6.0/plugin/i386/ns7
/libjavaplugin_oji.so .

I do not know which directory that I am supposed to activate this command, and whether this is one command or two separate commands lines, given that there are Mozilla folder, Firefox folder and Firefox-3.5.7 folder.

the command would be:

mkdir ~/.mozilla/plugins; cd ~/.mozilla/plugins; n -s /usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so .

Thats assuming the file you are linking exists, you can check using:

file /usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so

If you are told the file doesnt exists you need to review the link, if you get something else you are good to go

springtime (limlim88) said : #8

I remove all the previously installed Java files and start afresh by downloading the file for Linux, unpack it at /usr/java then, do the following commands as follow:

root@artlim66-desktop:/usr/lib/mozilla/plugins# ln -s /usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so .
root@artlim66-desktop:/usr/lib/mozilla/plugins# file /usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so
/usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so: ERROR: cannot open `/usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so' (No such file or directory)
root@artlim66-desktop:/usr/lib/mozilla/plugins#

When I go into the file system, I can see the file at /usr/java/jre1.6.0/plugin/i386/ns7/libjavaplugin_oji.so but somehow, when I try to link, error message as above says that no such file or directory.

Pls note that the jre1.6.0 folder is specified as jre1.6.0_17, is this the problem?

I also tried to go ahead with the first command of mkdir... and there was a error messge of n command doesnt exist.

springtime (limlim88) said : #9

Hi actionparsnip,

I tried out the command with the specific folder name of jre1.6.0_17 and it works! Thanks for all the follow up by all of you all. I greatly appreciated the efforts of you all.

The steps I told are:
1. Download the Java for Linux
2. I went to Applications-Acessories-Terminal, I then use the sudo -l command, which prompted for my password. It is the same password I used for my normal login (pls note it is -l, not -one, numeric character)
3. then I make use of sudo nautilus command to start up the window environment. I can then go to the usr folder to create the java folder.
4. I then copy the downloaded java .bin file into the java folder
5. I started another Terminal mode and again use the sudo -l command and key in the password accordingly as above
6. move the jave folder with /usr/java
7. issue the command as per SUN Java website: chmod a+x jre-6u<version>-linux-i586.bin
8. issue the next command: ls -l which requires user to scroll down the agreement by using Enter key till to end of message, which user needs to type in yes
9. issue the next command ./jre-6u<version>-linux-i586.bin (pls replace <version> with actual number, which is currently 17) and it requires user to scroll down the agreement by using Enter key till to end of message, which user needs to type in yes
10. Then move to the plugins folder by typing in /usr/lib/mozilla/plugins
11. Followed by this command ln -s /usr/java/jre1.6.0_17/plugin/i386/ns7/libjavaplugin_oji.so . (do not miss out the .
12. Eureka! It works. One trick I find it useful is to copy the commands and paste them, as you may type wrongly and read it wrongly.

Once again, Thanks to all who are so willingly to spend their precious time to help me through it all!