cannot write to hard disk

Asked by Chris on 2009-11-06

I installed Ubuntu for the first time on the first partition of a two partition drive.
The second partition is still in ntfs(winXP) format, I have some files on it that I don't want to delete.
The problem is that I can read from the second partition but cannot write to it. I get a message "Error while copying to "/media/SAMSUNG 80B".....You do not have permissions to write to this folder."
When the system starts I enter my username and password. So I think that I am the administrator.
When I right click on the drive and go to 'properties' - 'permissions' I cannot change anything, and it shows that the owner is 'root'.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-06
Last reply:
2009-11-06
Vu Do Quynh (vu-do-quynh) said : #1

As the owner is root, you cannot write to it.

If you need to write anything on it, either you change the owner from a terminal with a command like:

sudo chown -R username /media/Windows (or the name your NTFS partition is given, it should be mounted on /media normally)

or change the settings in the file /etc/fstab (you need to show the output of the command cat /etc/fstab first)

or (more simple but risky) do the following command in a terminal (or from run window ALT+F2) gksudo nautilus to open the NTFS partition in a Nautilus window as root

Shashank Sahni (shredder12) said : #2

Or you may even try changing the permission of the drive to 777.. I hope this will work too..
"sudo chmod 777 -R <your mounted partition>"

Can you help with this problem?

Provide an answer of your own, or ask Chris for more information if necessary.

To post a message you must log in.