Connecting to NAS using afp stopped working

Asked by Lou on 2019-01-31

I have two nearly identical machines running xubuntu 18.04. One mounts my NAS via AFP and works fine - on the other AFP has stopped working - it connects to the NAS but I can't access any files. Please help me track this down and fix it...

It's like the mount point for AFP is owned by Root, preventing access. I've searched the 'net but have been unable to find out where the mount point is. If any one knows please tell me where to look. I looked at permissions for the files; the owner is 65534 - don't know what this means...just checked the owner ID on the machine that works correctly - it's 33. Hopefully these clues will speak to someone who knows what they mean.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-05
Last reply:
2019-02-21

what is the output of:

lsb_release -a; uname -a; grep 65534 /etc/passwd

Thanks

Lou (lou-gregory42) said : #2

No LSB modules are available.

On Thu, Jan 31, 2019 at 8:57 AM actionparsnip <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> what is the output of:
>
> lsb_release -a; uname -a; grep 65534 /etc/passwd
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Run the whole command I gave not just part of it......

Lou (lou-gregory42) said : #4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
Linux lou-Latitude-E6420 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29
16:27:25 UTC 2019 i686 i686 i686 GNU/Linux
sync:x:4:65534:sync:/bin:/bin/sync
nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin
dnsmasq:x:104:65534:dnsmasq,,,:/var/lib/misc:/bin/false
kernoops:x:106:65534:Kernel Oops Tracking Daemon,,,:/:/bin/false
sshd:x:116:65534::/var/run/sshd:/usr/sbin/nologin
_apt:x:122:65534::/nonexistent:/bin/false

On Thu, Jan 31, 2019 at 9:13 AM actionparsnip <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Run the whole command I gave not just part of it......
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Then the file is owned by the "Nobody" user. The ID in your output shows this

Lou (lou-gregory42) said : #6

My 2 computers are nearly identical and neither has a "Nobody" user. On
the 2nd computer I am able to access the same files on the NAS that I
cannot access on the 1st computer - and, I used to be able to access them
on the 1st computer but now I cannot.

Your answer therefore does not resolve my problem but I sincerely thank you
for trying. It is indeed a vexing situation (and one that I probably
caused in some way). Several weeks ago I was trying to make some system
changes and, lacking the use of gksudo in the 18.04 release, I tried using
"sudo -H nautilus. I managed to change the ownership of some files in my
home directory to root and was able to chown them back to user but thought
this might have changed more things than I was able to find. Perhaps one
day I'll reinstall Ubuntu 18.04 from scratch, which will no doubt solve my
problem...

On Thu, Jan 31, 2019 at 11:42 AM actionparsnip <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Then the file is owned by the "Nobody" user. The ID in your output shows
> this
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #7

If you unmount the NAS on both client computers, what output do you receive for the command

ls -ld /name/of/the/mount/point

If you do not know the name of the mount point, issue the command

mount

to show it.

Lou (lou-gregory42) said : #8

Perhaps I'm doing something wrong- this is the output of 'mount' when the
NAS is not mounted on either machine:

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs
(rw,nosuid,relatime,size=4055188k,nr_inodes=187604,mode=755)
devpts on /dev/pts type devpts
(rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=816264k,mode=755)
/dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs
(rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/unified type cgroup2
(rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup
(rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/blkio type cgroup
(rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup
(rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/pids type cgroup
(rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup
(rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup
(rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup
(rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/perf_event type cgroup
(rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/devices type cgroup
(rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/rdma type cgroup
(rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/cpuset type cgroup
(rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/hugetlb type cgroup
(rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs
(rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=468)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/var/lib/snapd/snaps/core_6258.snap on /snap/core/6258 type squashfs
(ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_6037.snap on /snap/core/6037 type squashfs
(ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_6128.snap on /snap/core/6128 type squashfs
(ro,nodev,relatime,x-gdu.hide)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
tmpfs on /run/user/1001 type tmpfs
(rw,nosuid,nodev,relatime,size=816260k,mode=700,uid=1001,gid=1001)
tmpfs on /run/user/1000 type tmpfs
(rw,nosuid,nodev,relatime,size=816260k,mode=700,uid=1000,gid=1000)

should I be able to know what the name is from this?

On Fri, Feb 1, 2019 at 2:57 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> If you unmount the NAS on both client computers, what output do you
> receive for the command
>
> ls -ld /name/of/the/mount/point
>
> If you do not know the name of the mount point, issue the command
>
> mount
>
> to show it.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #9

Sorry, it seems that my instructions were formulated in a misleading way.

To find out the mount point, you have to execute the "mount" command when the NAS is mounted.
To see the file/directory access settings, you have to execute the "ls -ld ..." command, when the NAS is not mounted.

So please issue the command "mount" to identify the mount point for the NAS, then unmount it, and finally issue the "ls -ld /mount/point" command to see the access rights.

Lou (lou-gregory42) said : #10

I mounted the NAS in Nautilus, then entered the 'mount' command with this
result:

lou@lou-Latitude-E6420:~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs
(rw,nosuid,relatime,size=4055188k,nr_inodes=187604,mode=755)
devpts on /dev/pts type devpts
(rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=816264k,mode=755)
/dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs
(rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/unified type cgroup2
(rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup
(rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/blkio type cgroup
(rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup
(rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/pids type cgroup
(rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup
(rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup
(rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup
(rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/perf_event type cgroup
(rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/devices type cgroup
(rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/rdma type cgroup
(rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/cpuset type cgroup
(rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/hugetlb type cgroup
(rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs
(rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=468)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/var/lib/snapd/snaps/core_6258.snap on /snap/core/6258 type squashfs
(ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_6037.snap on /snap/core/6037 type squashfs
(ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_6128.snap on /snap/core/6128 type squashfs
(ro,nodev,relatime,x-gdu.hide)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
tmpfs on /run/user/1001 type tmpfs
(rw,nosuid,nodev,relatime,size=816260k,mode=700,uid=1001,gid=1001)
tmpfs on /run/user/1000 type tmpfs
(rw,nosuid,nodev,relatime,size=816260k,mode=700,uid=1000,gid=1000)

am I doing something wrong? Sorry if I seem thick...

On Fri, Feb 1, 2019 at 7:27 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> Sorry, it seems that my instructions were formulated in a misleading
> way.
>
> To find out the mount point, you have to execute the "mount" command when
> the NAS is mounted.
> To see the file/directory access settings, you have to execute the "ls -ld
> ..." command, when the NAS is not mounted.
>
> So please issue the command "mount" to identify the mount point for the
> NAS, then unmount it, and finally issue the "ls -ld /mount/point"
> command to see the access rights.
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #11

It seems that at the time of running the mount command the NAS was not mounted (or no more mounted).

How do you normally mount the NAS?

Lou (lou-gregory42) said : #12

In Nautilus I clicked 'other locations' and then selected 'wdmycloud' (my
NAS) and entered the user/password info when asked. I then saved the
location as a bookmark in Nautilus. When I want to access the NAS I click
the bookmark. The bookmark looks like this:

afp://<email address hidden>/Lou/

On Fri, Feb 1, 2019 at 8:17 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> It seems that at the time of running the mount command the NAS was not
> mounted (or no more mounted).
>
> How do you normally mount the NAS?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Lou (lou-gregory42) said : #13

I originally mounted to in Nautilus by selecting WDMyCloud from 'other
locations' and entering the necessary user/password. After AFP mounted the
NAS I saved the location as a bookmark and when I want to mount the NAS
again I click the bookmark. Bookmark looks like this:
afp://<email address hidden>/Lou/

On Fri, Feb 1, 2019 at 8:17 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> It seems that at the time of running the mount command the NAS was not
> mounted (or no more mounted).
>
> How do you normally mount the NAS?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #14

Which output do you receive for the command

ls -l /media /mount /mnt

(preferably executed on both systems)?

Lou (lou-gregory42) said : #15

First let me explain that the 'good' machine has only 1 user whereas the
'bad' machine has 2. Otherwise, no important differences. Both are
running xubuntu 18.04.1

The command you requested was run on both machines with NAS mounted by AFP

On the 'bad' machine:

ls: cannot access '/mount': No such file or directory
/media:
total 8
drwxr-x---+ 2 root root 4096 Feb 1 06:49 chris
drwxr-x---+ 2 root root 4096 Feb 1 10:18 lou

/mnt:
total 0

On the 'good machine;

ls: cannot access '/mount': No such file or directory
/media:
total 0

/mnt:
total 0

sorry for the delay - thank you for your efforts...

On Fri, Feb 1, 2019 at 1:58 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> Which output do you receive for the command
>
> ls -l /media /mount /mnt
>
> (preferably executed on both systems)?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> You received this question notification because you asked the question.
>

Lou (lou-gregory42) said : #16

Sorry to be a bother - just wondering if you have given up on my problem,
I did as you asked and sent the results on 2/1/19.

On Fri, Feb 1, 2019 at 3:32 PM Lou <email address hidden>
wrote:

> Your question #678238 on nautilus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
>
> Status: Needs information => Open
>
> You gave more information on the question:
> First let me explain that the 'good' machine has only 1 user whereas the
> 'bad' machine has 2. Otherwise, no important differences. Both are
> running xubuntu 18.04.1
>
> The command you requested was run on both machines with NAS mounted by
> AFP
>
> On the 'bad' machine:
>
> ls: cannot access '/mount': No such file or directory
> /media:
> total 8
> drwxr-x---+ 2 root root 4096 Feb 1 06:49 chris
> drwxr-x---+ 2 root root 4096 Feb 1 10:18 lou
>
> /mnt:
> total 0
>
> On the 'good machine;
>
> ls: cannot access '/mount': No such file or directory
> /media:
> total 0
>
> /mnt:
> total 0
>
> sorry for the delay - thank you for your efforts...
>
>
> On Fri, Feb 1, 2019 at 1:58 PM Manfred Hampl <
> <email address hidden>> wrote:
>
> > Your question #678238 on nautilus in Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
> >
> > Status: Open => Needs information
> >
> > Manfred Hampl requested more information:
> > Which output do you receive for the command
> >
> > ls -l /media /mount /mnt
> >
> > (preferably executed on both systems)?
> >
> > --
> > To answer this request for more information, you can either reply to
> > this email or enter your reply at the following page:
> > https://answers.launchpad.net/ubuntu/+source/nautilus/+question/678238
> >
> > You received this question notification because you asked the question.
> >
>
> --
> You received this question notification because you asked the question.
>

Launchpad Janitor (janitor) said : #17

This question was expired because it remained in the 'Open' state without activity for the last 15 days.