i can't get past my desktop, all the panels have been deleted, how do i restore the default settings?

Asked by Les on 2009-04-16

when i log on to my ubuntu installation there are no panels to provide shortcuts to computer resources.

i am asking if there is a way to return unbuntu to default setting.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
2009-04-18
Last query:
2009-04-18
Last reply:
2009-04-16
Les (lesnorth8) said : #1

if i installed kde desktop would that restore my gnome desktop?

Best Bhavani Shankar (bhavi) said : #2

Nopes

Course to a terminal (Press cntrl + alt +f1 or f2 in the login screen) Or boot up in recovery mode (Usually 2nd option in grub menu)

and give the following command:

sudo apt-get remove ubuntu-desktop

and

sudo apt-get install ubuntu-desktop

and reboot your system..

sudo reboot

Hope it helps

Bhavani Shankar.

Tom (tom6) said : #3

I think Shanker's answer is most likely to work but you might want to first try booting up as far as the menu with lots of Ubuntu options, choose the one that has "recovery mode" at the end of the line and try a few of these options especially the "dpkg fix broken packages". After that hasn't worked (worth a try but i don't think it will work) then Shanker's way should still work.

Good luck and regards from
Tom :)

christoph (christophs) said : #4

If you only want to return the panels to their default but not everything else, this method is better:
Log in and hit ALT-F2 and enter "gnome-terminal" (without the quotes).
Then, in the terminal that opens, enter
"rm -r /home/christoph/.gconf/apps/panel/ && killall gconfd-2 && killall gnome-panel".
(Without the quotes, you can paste in terminal using right-click paste).

Then you should have the default panels back.

christoph (christophs) said : #5

Oh, sorry, I can't edit my reply: I had a typo:

instead of this:
"rm -r /home/christoph/.gconf/apps/panel/ && killall gconfd-2 && killall gnome-panel"

run this command:

"rm -r ~/.gconf/apps/panel/ && killall gconfd-2 && killall gnome-panel"

Otherwise it won't work if your username isn't also christoph ;).

Tom (tom6) said : #6

lol, nice one christoph :) I linked to a bug-report about not being able to edit answers as it would have helped here. It often happens this way so don't worry!
Good luck and regards to all from
Tom :)

Les (lesnorth8) said : #7

Thanks Bhavani Shankar, that solved my question.

Tom (tom6) said : #8

Brilliant, nicely done. Wecome to Ubuntu :)

Regards from
Tom :)

sudo apt-get remove ubuntu-desktop

and

sudo apt-get install ubuntu-desktop

and reboot your system..

sudo reboot

                             BEST OF LUCK. THIS SHOULD WORK.

On Thu, Apr 16, 2009 at 12:34 PM, Les
<email address hidden>wrote:

> New question #67626 on nautilus in ubuntu:
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/67626
>
> when i log on to my ubuntu installation there are no panels to provide
> shortcuts to computer resources.
>
> i am asking if there is a way to return unbuntu to default setting.
>
> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

shafiq shah (kingofpisces) said : #10

ohh thnxx alott christoph.. ivee got it backk my topp panell wass justt dissapeared.. ;) thnxx again