NFS files do not show in Nautilus listing of files

Asked by ealthuis on 2018-05-18

Using Network File Service, i have access to specific files on the NFS server directly from any of my computers set up to do so.
 In all but the one with 18.04 LTS (the others still run 16.04 LTS), the names of the files on the server show, with immediate access.

On the 16.04LTS computers when I open the files icon, all files show including the NFS files, the listing has Recent, Home, Documents, Downloads, Pictures etc as well as mass , mass1 etc plus the other disk of 40GB. On the 18.04LTS listing only Recent, Home, Documents, Downloads, Pictures etc

How do I make Nautilus show what I need to see on this 18.04 LTS computer.

I have screen shots, bu know no way of attaching them to this question

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2018-05-22
Last query:
2018-05-22
Last reply:
2018-05-22

If you use Dropbox or Imageshack or similar then you can make a URL of the image and post the URL

If you manually mount the NFS is it OK?

ealthuis (ealthuis) said : #4

Have much difficulty executing the mount command.

ea@azura:~$ sudo mount -a NFS --source //192.168.9.103/export/mass0 --target /media/mass0
[sudo] password for ea:
ea@azura:~$ ls -l /media/mass0
total 0
ea@azura:~$

There are 2 files in mass0.
Please help me with the mount command so that I can prove my problem as I see it

ealthuis (ealthuis) said : #5

I made a small error above, a nine in place of a zero, results are the same

ea@azura:~$ sudo mount -a NFS --source //192.168.0.103/export/mass0 --target /media/mass0
[sudo] password for ea:
ea@azura:~$ ls -l /media/mass0
total 0
ea@azura:~$

Try:

sudo mount 192.168.0.103:/export/mass0 /media/mass0

Does that work OK?

ealthuis (ealthuis) said : #7

Yes the mount command worked fine, however in order to see the actual files in the partition I have to go to"other locations", from there to "computer" and finally to the folder /media, where I find mass0 (and the others). This is the long way around , as I said on all the other computers these mounted partitions show in the list of folders as soon as nautilus is opened. And that is the problem still.

All I can suggest is add the mount to /etc/fstab then add the mount point in your favourites in Nautilus

ealthuis (ealthuis) said : #9

As this is not a life and death problem, I will accept that the question has been answered, but certainly not solved.

I primarily use this computer for eMail and use the access to the other mounts when ever I need to save a file. I can handle that using the long way around.

Thanks for your help