Ubuntu won't mount new usb flash drive

Asked by Charlie Adams on 2008-12-08

I bought a new usb flash drive and Was hoping to use it to transfer info between my ubuntu machines. The problem is I get an error message that says Unable to mount location and under that it says "can't mount file". My experience with linux and ubuntu are very limited. Does a new drive need to formated for ubuntu to read it? Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Charlie Adams
Solved:
2008-12-10
Last query:
2008-12-10
Last reply:
2008-12-09
Wyatt Smith (wyatt-smith) said : #1

You may need to configure /etc/fstab to mount usb flash drive automatically. The following page may be helpful.
https://help.ubuntu.com/community/Fstab

If you are still unable to mount your usb drive, please open a terminal and type

sudo blkid
cat /etc/fstab
sudo fdisk -l

Please tell... the output of these commands.

Thanks

Charlie Adams (chasmo07) said : #2

please understand you are dealing with a nube. I will do the best I Can to
follow directions and learn what I can. Thanks for your help.
Here is the out put from the commands
charlie@charlie-laptop:~$ sudo blkid
[sudo] password for charlie:
/dev/sda1: UUID="26e9bcb2-2d1a-4b6a-8e54-ab58e3490265" TYPE="ext3"
/dev/sda5: TYPE="swap" UUID="eaa86d78-d42f-423a-a201-6c65182a279a"
/dev/sdb1: LABEL="CORSAIR" UUID="30E8-EC0A" TYPE="vfat"
charlie@charlie-laptop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=26e9bcb2-2d1a-4b6a-8e54-ab58e3490265 / ext3 relatime,errors=remount-ro
0 1
# /dev/sda5
UUID=eaa86d78-d42f-423a-a201-6c65182a279a none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
charlie@charlie-laptop:~$ sudo fdisk-l
sudo: fdisk-l: command not found
charlie@charlie-laptop:~$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000dda88

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9565 76830831 83 Linux
/dev/sda2 9566 9729 1317330 5 Extended
/dev/sda5 9566 9729 1317298+ 82 Linux swap / Solaris

Disk /dev/sdb: 8086 MB, 8086618112 bytes
255 heads, 63 sectors/track, 983 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x04dd5721

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 984 7897056+ b W95 FAT32
Partition 1 has different physical/logical endings:
phys=(982, 254, 63) logical=(983, 36, 13)
charlie@charlie-laptop:~$ sudo apt-get install nfs-kernel-server nfs-common
portmap

On Dec 8, 2008 6:04pm, Wyatt Smith <email address hidden>
wrote:
> Your question #53893 on nautilus in ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> Status: Open => Answered
>
>
>
> Wyatt Smith proposed the following answer:
>
> You may need to configure /etc/fstab to mount usb flash drive
automatically. The following page may be helpful.
>
> https://help.ubuntu.com/community/Fstab
>
>
>
>
>
> If you are still unable to mount your usb drive, please open a terminal
and type
>
>
>
> sudo blkid
>
> cat /etc/fstab
>
> sudo fdisk -l
>
>
>
> Please tell... the output of these commands.
>
>
>
> Thanks
>
>
>
> --
>
> If this answers your question, please go to the following page to let us
>
> know that it is solved:
>
>
https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893/+confirm?answer_id=0
>
>
>
> If you still need help, you can reply to this email or go to the
>
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> You received this question notification because you are a direct
>
> subscriber of the question.
>

Wyatt Smith (wyatt-smith) said : #3

From the terminal

Create a mountpoint.
sudo mkdir /media/CORSAIR

To edit your /etc/fstab with root permission
sudo gksu gedit /etc/fstab

Please add these lines

# USB Flash Drives - Corsair
UUID=30E8-EC0A /media/CORSAIR vfat defaults 0 0

Save and exit.

To mount all drives in your /etc/fstab file
sudo mount -a

Hope this helps

Charlie Adams (chasmo07) said : #4

Thanks. I tried your solution and it still won't mount. Here is what I have
done. does it look right to you?

charlie@charlie-laptop:~$ sudo mkdir /media/CORSAIR
[sudo] password for charlie:
charlie@charlie-laptop:~$ sudo gksu gedit /etc/fstab
charlie@charlie-laptop:~$ sudo mount -a
mount: special device /dev/disk/by-uuid/30E8-EC0A does not exist
charlie@charlie-laptop:~$

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=26e9bcb2-2d1a-4b6a-8e54-ab58e3490265 / ext3 relatime,errors=remount-ro
0 1
# /dev/sda5
UUID=eaa86d78-d42f-423a-a201-6c65182a279a none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
# USB Flash Drives - Corsair
UUID=30E8-EC0A /media/CORSAIR vfat defaults 0 0

Thanks again for your help. Charlie

On Dec 8, 2008 8:27pm, Wyatt Smith <email address hidden>
wrote:
> Your question #53893 on nautilus in ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> Status: Open => Answered
>
>
>
> Wyatt Smith proposed the following answer:
>
> >From the terminal
>
>
>
> Create a mountpoint.
>
> sudo mkdir /media/CORSAIR
>
>
>
> To edit your /etc/fstab with root permission
>
> sudo gksu gedit /etc/fstab
>
>
>
> Please add these lines
>
>
>
> # USB Flash Drives - Corsair
>
> UUID=30E8-EC0A /media/CORSAIR vfat defaults 0 0
>
>
>
> Save and exit.
>
>
>
> To mount all drives in your /etc/fstab file
>
> sudo mount -a
>
>
>
> Hope this helps
>
>
>
> --
>
> If this answers your question, please go to the following page to let us
>
> know that it is solved:
>
>
https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893/+confirm?answer_id=2
>
>
>
> If you still need help, you can reply to this email or go to the
>
> following page to enter your feedback:
>
> https://answers.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> You received this question notification because you are a direct
>
> subscriber of the question.
>

Tobias Wolf (towolf) said : #5

Charlie, Wyatt, the inctructions that are meant to add the flash drive to fstab are not really good for a removalbe disk. The fstab is more useful for permanent disks that don't get hot-plugged.
The real question is why doesn't Ubuntu mount the stick automatically, when it gets inserted. This information that Charlie posted is interesting:

Disk /dev/sdb: 8086 MB, 8086618112 bytes
255 heads, 63 sectors/track, 983 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x04dd5721

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 984 7897056+ b W95 FAT32
****** Partition 1 has different physical/logical endings: ******
phys=(982, 254, 63) logical=(983, 36, 13)

Maybe the factory formatting was not valid and so Uubntu didn't mount because of that.

My suggestion would be to remove the entry from fstab again; just because a flash drive is not meant for permanent mounting. Then, personally, I would reformat the drive.

If you want to try, this is how you do it with graphical programs:

sudo gparted # enter in a terminal

Then delete the partition, and create a new primary partition in it's place, and format this empty partition as vfat (a.k.a FAT32). You can specify a readable label in the format dialog, like "CORSAIR" or whatever else you like. Apply the changes (green checkmark button), and close the program, re-plug the drive and see whether it becomes mounted automatically.

What do you think?

Tobias Wolf (towolf) said : #6

Oh, make that

sudo gparted /dev/sdb

just to make sure that the flash drive becomes the selected drive, so that you don't remove your system partition by accident.

Charlie Adams (chasmo07) said : #7

Again thanks.. Ok I want to be sure on this.
1. I should go to fstab and remove the lines that were added.

To edit your /etc/fstab with root permission
sudo gksu gedit /etc/fstab

then remove the lines....
# USB Flash Drives - Corsair
UUID=30E8-EC0A /media/CORSAIR vfat defaults 0 0

Then in terminal type sudo gparted /dev/sdb

This is the result of sudo gparted /dev/sdb

charlie@charlie-laptop:~$ sudo gparted /dev/sdb
[sudo] password for charlie:
sudo: gparted: command not found
charlie@charlie-laptop:~$ sudo gparted /dev/sdb
sudo: gparted: command not found
charlie@charlie-laptop:~$
I really am a nube. I pretty much have to have it exact to get anything
done. Sorry. am I right thinking that gparted is a tool used to partition a
drive? Is it or done in terminal? and once it is formated should ubuntu
mount it automaticly?

On Dec 9, 2008 11:56am, Tobias Wolf <email address hidden>
wrote:
> Your question #53893 on nautilus in ubuntu changed:
>
> https://answers.edge.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> Tobias Wolf requested for more information:
>
> Oh, make that
>
>
>
> sudo gparted /dev/sdb
>
>
>
> just to make sure that the flash drive becomes the selected drive, so
>
> that you don't remove your system partition by accident.
>
>
>
> --
>
> To answer this request for more information, you can either reply to
>
> this email or enter your reply at the following page:
>
> https://answers.edge.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> You received this question notification because you are a direct
>
> subscriber of the question.
>

Charlie Adams (chasmo07) said : #8

Ok I went out and found Gparted and got it installed on my machine. I found
the flash drive and it says it is formated for fat32. Do you think it needs
to be deleted and reformated to the same thing? Charlie

On Dec 9, 2008 11:56am, Tobias Wolf <email address hidden>
wrote:
> Your question #53893 on nautilus in ubuntu changed:
>
> https://answers.edge.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> Tobias Wolf requested for more information:
>
> Oh, make that
>
>
>
> sudo gparted /dev/sdb
>
>
>
> just to make sure that the flash drive becomes the selected drive, so
>
> that you don't remove your system partition by accident.
>
>
>
> --
>
> To answer this request for more information, you can either reply to
>
> this email or enter your reply at the following page:
>
> https://answers.edge.launchpad.net/ubuntu/+source/nautilus/+question/53893
>
>
>
> You received this question notification because you are a direct
>
> subscriber of the question.
>

Charlie Adams (chasmo07) said : #9

Gentelmen. Thanks for your help. I followed your advice and removed the lines in fstab. I used gparted to delete the partition and reformat it back to fat32. Which it was already. Not sure why that worked but it did. My laptop now recognizes the new flash drive. Thanks for the ideas. Now I will see if my other computers will recognize it. Thanks again. Charlie