Acer Aspire One Notebook Bios password Loced out!!!

Asked by Sun Dragon 777 on 2008-11-03

Acer Aspire One Notebook- Bios password Loced out!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Guillermo Belli
Solved:
2011-01-07
Last query:
2011-01-07
Last reply:
2008-12-03

Did you mount the USB device as root??

Sun Dragon 777 (sundragon777) said : #2

No, I simply plugged in the memory stick or flash drive into a USB (or reader) slot, as a user within the root group, but no, not as root.

Why? Should I have to mount the USB drive as root in order to write to it?

These USB (flash/jump or memory sticks) drives have already been written to via Windows XP. I can view these files, but not seem to be able to copy any to the drives? Do I need to have them partitioned/formatted for Linux before I can write to them?

Thanks for any assistance and light that you might be able to shed on the matter.

Rei Heru

Sun Dragon 777 (sundragon777) said : #3

Please, someone provide me with info related to the problem:

I cannot get any external drive (disk or memory drive) to work properly with uBuntu 7.10; I can mount the drive(s) and read the files on the drives (written in Windows XP), but I cannot write to any of the drives!

I just purchased a new external hard drive, Western Digital "My Passport" USB-powered, for backing up my directories and files in Ubuntu. However, I still cannot write to the drive, or any other. I can mount and view the files currently existing on the drive, but when I try to copy/write files to the disk, I receive the
"Invalid parameters . . ." error message, as I ahve with all other external drives I try to write to.

What do I need to do to get things working properly?
Thanks,

Rei-

Guillermo Belli (glock24) said : #4

Older versions of GNU/Linux did not include a ntfs driver with writing support, as they used the old ntfs driver. Newer distributions use the ntfs-3g driver, which provides read and wirte support under GNU/Linux.

Also, some older Ubuntu versions that included support for ntfs-3g had incomplete fuse (filesystem in userspace) and hal (hardware abstraction layer) configuration, so that some people could not mount or write to external disks.

You can try to install the ntfs-3g support this way:

Open up a terminal and type this:

sudo apt-get install ntfs-3g fuse-utils libfuse2 ntfs-config

After these packages get installed, type this:

sudo ntfs-config

A windows will appear, there, check the box that says "Enable write support for external devices", and you should be set.

If you are using your external disk only for GNU/Linux, you should change it to a native format like ext3, like this:

sudo mkfs.ext3 /dev/sdxx

Where /dev/sdxx is your disk. This will format your disk, so anything pesent in it will be erased, so use with caution.

Hope this helps.

Sun Dragon 777 (sundragon777) said : #5

Hi Guillermo

Thanks for the response.

You state that for older versions of GNU/Linux the ntfs support was not included/supported. Would this be the case with "Gutsy Gibbon" (Ubuntu 7.10)? This is the version that I am running and I thought it was fairly new and could handle (according to the advertised features of 7.10) external ntfs/fat filesystems.
Should I need to install these packages on 7.10? If so, I'll proceed with your specified steps.

Thank you much for your efforts!

Rei-

Guillermo Belli (glock24) said : #6

Rei,

Ubuntu 7.10 did include support for ntfs drives, but as I stated, has truble with external storage devices, so Install the packages I suggested and run ntfs-config.

Well, Ubuntu 7.10 is not very old, as it was released in October 2007, but the GNU/Linux world moves very fast and there have been 2 Ubuntu versions since 7.10.

The current version is 8.10 Intrepid Ibex, and it contains lots of new features and improvements.

Sun Dragon 777 (sundragon777) said : #7

Thank You Very Much!

I will proceed with the procedure as you have stated above and let you know how things work out.

Will be in touch . . .

Rei-

Best Guillermo Belli (glock24) said : #8

Rei, did it work?

Sun Dragon 777 (sundragon777) said : #9

Thanks Guillermo Belli, that solved my question.

Sun Dragon 777 (sundragon777) said : #10

Sorry for this very late closing remark-comment. I did do as suggested and all worked fine.

The problem was that the new (at that time) Western Digital HD was formatted as FAT32; I was under the assumption that these current external Passport drives were all ntfs. I installed the ntfs packages, as suggested by Guillermo, reformatted the drive the ntfs, and was able to both read & write successfully to the drive. Things have worked fine since then. Plus I've upgraded to the various major release of Ubuntu since, and have had no problem since.

Happened to see this question in the db when I just recently submitted one for a completely different issue.

And by the way, the title for this question/problem - "Acer Aspire One Notebook Bios Password Locked Out" - is completely wrong/incorrect for this problem. It had nothing to do with what the present title suggests. Never owned and Acer anything . . . this problem had only to do with writing to an external hd or flash stick. Must have been some corruption in the db table space over time. No worries though, as this problem was resolved over two years ago. Just thought I'd bring final closure to it and set the record straight about the title.

Again, thank you all for helping me resolve this issue.