nautilus cant start from root

Asked by kimatib on 2008-11-01

Binary package hint: nautilus

command issued: nautilus . #from root

(nautilus:10214): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.

(nautilus:10214): Eel-WARNING **: GConf error:
  Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://www.gnome.org/projects/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

Description: Ubuntu 8.10
Release: 8.10
The problem started after upgrade from Hardy Heron.
I think it has to do with the replacement of configuration files.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
kimatib
Solved:
2008-11-02
Last query:
2008-11-02
Last reply:
2008-11-02

This question was originally filed as bug #291988.

Mackenzie Morgan (maco.m) said : #1

Are you trying to do it from a root console or by using "gksu"? Root won't have an instance of gconfd running since it's not logged into GNOME, which could explain the gconf error.

kimatib (kimatib) said : #2

yeh--i tried with gksudo and it works fine.
but b4 i could run nautilus from terminal with root but now it gives the error shown above.

Mackenzie Morgan (maco.m) said : #3

Before were you using sudo or a root shell? And if a root shell, did you reach that root shell with "sudo -s" or "sudo -i"?

kimatib (kimatib) said : #4

i usually go into root using su

I think is better use nautilus as root using a different method, please open a terminal and type:

sudo nautilus

or

press alt + f2 on a desktop without already opened windows and type into opened window:

gksudo nautilus

Hope this helps

kimatib (kimatib) said : #6

well, it seems that when i run: sudo nautilus
or gksudo nautilus
nautilus run ok without any errors.
the problem is when i run: su nautilus
but i think i can work with the other two ways.
thanks.