Where is the icon for a file type set?

Asked by David Tangye on 2008-08-28

All file types seem to have their appropriate icon, except the jpg files have the icon for text files in Nautilus. Their Type is 'jpg document', whereas gif and png are reported as 'gif image' and 'png image', not '...document'.

The problem arose subsequent to a problematic upgrade to Hardy, (reported on Launchpad at https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/249340). I think I have fixed the system, but just this problem remains visible.

Where do I fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
David Tangye
Solved:
2008-08-31
Last query:
2008-08-31
Last reply:
2008-08-30
David Tangye (davidtangye) said : #2

Thanks, that helps. I still do not have the answer though.

It appears that icons are stored in /usr/share/icons/(theme). However on my system Nautilus thinks jpgs are a 'jpg document', not a 'jpg image', and does not give them an appropriate icon. I can guess that it is going into /usr/share/icons/(theme), but it is selecting an icon based on 'jpg document', and shows a document type of icon. So my question is 'How do I get Nautilus to correctly recognise jpgs?'

Also it should be showing a thumbnail of the image anyway, not an icon. It does so for pngs and gifs. Where is the NAutilus configuration item that I can change to do this?

Tang (robertmcgreg) said : #3

Hi David,
Have you tried right clicking an offending file in Nautilus and correcting file association options and properties there?

David Tangye (davidtangye) said : #4

That only affects a single file.

I finally found the answer: Something seems to have run updata-mime-database on my user account, so it had created a personal 'shared MIME-Info database cache" at $HOME/.local/(?mime). I deleted this and everything is Ok now.

David Tangye (davidtangye) said : #5

To be exact, I am failry sure that it was $HOME/.local/share/mime that got erroneously built, and populated with files similar to /usr/share/mime. So -

rm -rf $HOME/.local/share/mime

fixed the problem.