Can't see folders on external hard drive

Asked by Eike on 2016-01-22

I connected my external harddrive to my computer which runs on ubuntu 12.04. The systems mounts the harddrive but I can't see any files, even with 'show hidden folders' activated.
The hardrive was used on ubuntu with another computer before, but was connected to a windows run computer a few times and worked fine. I had that problem before and needed to copy all my files from hardrive to another computer and back on.
Is there any way to prevent that procedure?

Thanks!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Last query:
2016-01-24
Last reply:
2016-01-24

When you unplug the drive, do you use the safe remove feature in the OS?

What file system is it using?

Thanks

Eike (ejpernst) said : #2

Thanks for the answer!

Yes I use the safe remove feature.
How can I find out which file system it is using?

thank you

Manfred Hampl (m-hampl) said : #3

What is the output of the diagnostic commands

uname -a
lsb_release -crid
sudo fdisk -l
mount

More than likely an NTFS partition. You may want to run a full chkdsk on the partition in Windows to make sure that the data is consistent.

Eike (ejpernst) said : #5

Manfred Hampl:
outup is 'uname: invalid option --c'

actionparsnip:
thank you i'll try that

Thanks for the answers!

Eike (ejpernst) said : #7

I connected the harddrive to a windows computer and could see all of the files on the harddrive

Eike (ejpernst) said : #8

And I checked ist uses NTFS file system

Run a full chkdsk on the file system in Windows. Then use a safe remove feature in the OS. Then pull the drive out but only when told. Then try the drive in Ubuntu

Can you help with this problem?

Provide an answer of your own, or ask Eike for more information if necessary.

To post a message you must log in.