in ubuntu 10.10 what app do i use to install latest firefox

Asked by scott on 2015-09-02

     archive manager always tries to open .exe files that just need to open and install. what application should i use? it keeps getting error, this file must not be a zip file.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
arochester
Solved:
2015-09-02
Last query:
2015-09-02
Last reply:
2015-09-02
Best arochester (arochester) said : #1

10.10 Maverick Meerkat reached the end of its life on 10th October 2012.

You need a new install

If you want a version that lasts longer go for an LTS (Long Term Support) version . 12.04 LTS will last until 2017, 14.04 LTS will go on until 2019.

I suggest studying the following documents to learn more about Ubuntu:

https://help.ubuntu.com/community/ExternalGuides

https://wiki.ubuntu.com/Releases

scott (lennyback) said : #3

Thanks arochester, that solved my question.