How to Mount Usb Disk?

Asked by Fr C J White on 2007-12-26

I have a USB -- connected External drive. It worked fine until recently. Now it doesn't show. When I tried to mount it, I got the message 'unable to mount media' Nearly all my work is stored on this Drive.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Sébastien Corriveau
Solved:
Last query:
Last reply:
Revision history for this message
Robert Di Gioia (digioiar) said :
#1

Hi!

Can you paste the contents of your /etc/fstab file here?

Thanks

Revision history for this message
Fr C J White (frcjwhite) said :
#2

I am illiterate in Computer language. Please, where do I find the contents of /etc/fstab file?

Revision history for this message
Olivier (olivier-lacroix) said :
#3

Hi !

open a terminal, and enter the following command

cat /etc/fstab

paste here the output

Revision history for this message
Fr C J White (frcjwhite) said :
#4

bash: cat/etc/fstab: No such file or directory

Revision history for this message
Fr C J White (frcjwhite) said :
#5

on start up 'error in device sdb1 logical bloc 1!
and more too fast for me to read.

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#6

There is a space between "cat" and "/etc/fstab". Do it again:

cat /etc/fstab

Revision history for this message
Fr C J White (frcjwhite) said :
#7

bash: cat/etc/fstab: No such file or directory

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#8

Try this:

cd /etc

press enter

gedit fstab

copy and paste the file content here

Thank you

Revision history for this message
Fr C J White (frcjwhite) said :
#9

 cd/etc
bash: cd/etc: No such file or directory
frcjwhite@frcjwhite-desktop:~$ geditfstab
bash: geditfstab: command not found

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#10

Looks like got a problem with your spacebar, didn't you?

You have to make sure there is at least one space between the two on the command line. You can "cut'n'paste" the following command to make sure you get it right.

cat /etc/fstab

You'll get it, we all know you're can ;-)

Revision history for this message
Fr C J White (frcjwhite) said :
#11

frcjwhite@frcjwhite-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=ecf0aa2d-9b2f-4b88-8bc9-783e1d67738f / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=84C06815C0680FAA /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=3E8E7FB98E7F6873 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda6
UUID=0814E1CC14E1BD36 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda7
UUID=49fbb35f-261a-4351-ba01-42066402871a none swap sw 0 0
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#12

Your last line ("/dev/ /media") is invalid. The first field must describe the block device or remote filesystem to be mounted and "/dev/" is neither. I don't know if it's the cause of your problem but I would start by removing it. To do it, type the following command into a terminal: sudo gedit /etc/fstab

Note that there are spaces between "sudo", "gedit" and "/etc/fstab".

Then, insert a "#" before the first character of the last line.

Before:
/dev/ /media

After:
#/dev/ /media

Reboot your system and try again.

Revision history for this message
Fr C J White (frcjwhite) said :
#13

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
When I

UUID=ecf0aa2d-9b2f-4b88-8bc9-783e1d67738f / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=84C06815C0680FAA /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=3E8E7FB98E7F6873 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda6
UUID=0814E1CC14E1BD36 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda7
UUID=49fbb35f-261a-4351-ba01-42066402871a none swap sw 0 0
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0

Revision history for this message
Fr C J White (frcjwhite) said :
#14

When I tried "sudo", "gedit" and "/etc/fstab"., it looked for password and then this is what came. I thought it better to l;et you see it breore I did any more!
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=ecf0aa2d-9b2f-4b88-8bc9-783e1d67738f / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=84C06815C0680FAA /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=3E8E7FB98E7F6873 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda6
UUID=0814E1CC14E1BD36 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda7
UUID=49fbb35f-261a-4351-ba01-42066402871a none swap sw 0 0
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0

Many thanks for your interest and expertise'

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#15

Are you having the error message as soon as you plug it into the USB port or do you need to manually mount it to get the error?

Is this device plugged in when you boot the system or is it added after the system has booted.

Have you try to plug a different drive into the USB port to see if it mounts?

If you boot from the Live CD and then connect the USB drive, does it works?

Revision history for this message
Fr C J White (frcjwhite) said :
#16

Thank you again for your interest. There is no error message. When I try to mount the disk,It says simply 'unable to mount media'. 'There is probably no media in the drive'
The device is plugged in to a USB hub before system is booted.
The answer to Q. 3 is Yes.
Ubuntu is installed so I no longer use the live cd.

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#17

I'd like you to try to boot from the Live CD with no USB drive connected. Once the computer has finished booting, connect the USB drive directly to the computer, not into the USB hub, and tell me if you got the same problem.

This will tells us if the problem is related to your Ubuntu configuration or if the problem comes from the drive or the filesystem.

Revision history for this message
Fr C J White (frcjwhite) said :
#18

I tried out your suggestion but, I'm sorry to say, the result is the same as before.
Thank you again for your continuing interest. Cjw

Revision history for this message
Sébastien Corriveau (sebcor-deactivatedaccount) said :
#19

Earlier, you said that your system was giving you some error during startup: "error in device sdb1 logical bloc 1!"

Does those messages disappears if you boot without the USB drive connected?

Do you know what filesystem is on that drive (fat32, ext3, ntfs, ...)?

Revision history for this message
Best Sébastien Corriveau (sebcor-deactivatedaccount) said :
#20

I haven't head from you since last week, do you got your problem fixed?

I was suspecting a filesystem corruption on your USB drive but you never replied to my last questions.

Please mark this question as "solved" if you don't need help anymore or give us more information if you do.

Revision history for this message
Fr C J White (frcjwhite) said :
#21

Thank you again for your expertise and continuing interest. Eventually I brought the external drive to a computer shop on Monday,21 Jan. and it is only now that I got the verdict. "Disk damaged, Data gone". So, I reckon that's it! Many thanks again and apologies for long delay.

Revision history for this message
Fr C J White (frcjwhite) said :
#22

Thanks Sébastien Corriveau, that solved my question.

Revision history for this message
Bhaumik (bhaumik-1086) said :
#23

Hi All,
I am sawing this type of error when i am going to mount my USB pendrive.

"You can stop this operating by clicking cencle."

"DBus error org.freedesktop.DBus.Error.NoReply: Did not received a reply. Possible causes include: the remote application did not send a reply, The massage bus security policy blocked the reply, The reply timeout expire, or the network connection was broken."

"Invalid mount option when attempting to mount the volume "________"

If any body have any solution for this type of error please send me mail on "<email address hidden>".