"save as" crashes any application, issue with mime type detection ?

Asked by Karsten Weber on 2011-09-18

--edit Sep 19--
update:
now I have tried 3 different ways from terminal to retrive mime information from a .txt file on a davs:// resource with the problems on mime type detection in Nautilus, if the drive is mounted to Places via "Connect to Server..." the result is quiet interesting:

   nn@n1:~$ file --mime '/home/nn/.gvfs/WebDAV on webdav.mc.gmx.net/linuxtest.txt'
                                            /home/nn/.gvfs/WebDAV on webdav.mc.gmx.net/linuxtest.txt: text/plain; charset=us-ascii

   nn@n1:~$ gnomevfs-info -s '/home/nn/.gvfs/WebDAV on webdav.mc.gmx.net/linuxtest.txt'
                              Name : linuxtest.txt
                              Type : Regular
                              MIME type : text/plain
                              ...

   nn@n1:~$ gnomevfs-info -s davs://webdav.mc.gmx.net/linuxtest.txt
          You must log in to access webdav.mc.gmx.net:443/GMX Mediacenter
          Username: <email address hidden>
          Password: ********
                    Name : linuxtest.txt
                    Type : Regular
                    MIME type : application/octetstream
                    ...

two times OK, one went wrong, always the same file on the same location. Only unfortunately the path in the latter case is exactly the one you have to take if accesing the drive via Nautilus. What if I try to navigate to "~/.gvfs/WebDAV on webdav.mc.gmx.net" in Nautilus to try to acces the files from there? Its not working, the directory seems to be empty and I am automaticaly redirected to "WebDAV on webdav.mc.gmx.net" rsp. "WebDAV on webdav.mc.gmx.net" in places where the problem persists. IMHO this looks like a bug. Isnt it?

--end edit--

With any application: on choosing "save as", as soon as I navigate to any location that has a problem with mime type detection (see text below, copied from my previous post to the Forum) the dialog and the application crashes. Could be a bug?
Via "open with other application" I can open and edit any file from such a location. I also may save it back via menu "File/Save" but if I choose "File/save as" the application crashes instantaneously.
After starting gedit from a terminal window and trying to save any .txt file to such a location, one can find the text "Segmentation failure" after the crash in terminal.

(Ubuntu 10.04 - davs://web.resources mounted via "connect to server" in Nautilus)

-- previous post: --

I have several webdavs network drives, that I can mount in NAUTILUS via bookmarks.
Some of them work fine, some are coming upwith only the mimetype "application/octetstream", (which is translated into "application/octetstream typ") - for any file-extension. Note: there is no slash in octetstream! in the mime database there is only the type "application/octet-stream" registered.
So I added an alias <alias type="application/octetstream"/> to the entry in /usr/share/mime/packages/freedektop.org.xml and did udate the mime database.
This changed the situation so far, that now the files type is translated from "application/octetstream" to "application/octet-stream" and the friendly name "unknown" is shown.
Not realy the solution, because I can not doubleclick to open with the default appl.
If I would choose to open the "unknown" filetype always with e.g. gedit, all files from this server, regardles of .jpg, .txt and so on would be opened in future with the same appl.

Is there any way, to convince Ubuntu/Nautilus to use for this server connections only the file extension istead of the mime type comming from the server, to apply only the mimetyps given in globs?

I am using 10.04 (standard, not netbook), on an intel netbook. The problem is independend from wether I use my EN or GE language settings.

I have tried the following Webdavs Servers:

davs://webdav.hidrive.strato.com/ --> works fine
davs://webdav.mc.gmx.net/ --> mime type problem
davs://sd2dav.1und1.de/ --> mime type problem

I also have several FTP servers that I mount in the same way, none of these has shown the problem with the mime types.

In WinXP I do not have this problem using "Netrive", neither the next yet unsolved problem, wich could possibley be a separate thread:

There is also an issue regarding different character encodings from different servers.
Can anybody tell, which (of the at least 4 - this is very confusing to me) method NAUTILUS uses, to mount external FTP, SFTP and davs Servers that are listened in bookmarks ? So I could write my own bash scripts to mount them manualy and have them afterwards in places, able to unmount them manualy with one click and without the need of sudo?
Doing so could (maybe) solve two problems: i) possibly the encoding to be used on a certain server could be defined in the script (you can't define it for servers listed in bookmarks), and ii) I am running out of space in bookmarks, it would be niche to have only a parent folder in bookmarks e.g. "WebDrives" wherein you can find all possible web based resources to mount with a click.

Question information

Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.