Nautilus-actions and Unity Desktop

Asked by kylea on 2011-04-18

What are the plans for integrating Nautilus-actions and Unity Desktop to allow the Right Click context menu to reflect Items from the Nautilus-actions app.

The menu items appear in Nautilus with a Right Click but not on the Desktop.

I love the Unity Launcher (it is a bit slow when using the mouse) however I must have the freedom to tailor the Right Click Context menu.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-18
Last reply:
2011-04-18

Can you give the output of:

lsb_release -a; uname -a; apt-cache policy nautilus-actions

Thanks

kylea (kylea) said : #2

lsb_release -a; uname -a; apt-cache policy nautilus-actions
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Natty (development branch)
Release: 11.04
Codename: natty
Linux kylea-laptop-lucid 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
nautilus-actions:
  Installed: 3.0.5-1
  Candidate: 3.0.5-1
  Version table:
 *** 3.0.5-1 0
        500 http://archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status

I suggest you run:

ubuntu-bug nautilus-actions

And log a bug. You are using the version from the official ubuntu repos, so this will work.

kylea (kylea) said : #4

Ok will do - so it should work

I recommend you log in to the traditional desktop and see if it works there. It may be Unity causing it not to work. It should work though and is a regression bug, what once worked now does not.

kylea (kylea) said : #7

Apparently this must have been a bug in Nautilus-Actions - the developer has indicated that 3.1.2 works.

Seeing as 11.10 is planned for 3.0.5 we may need a version update -

I have tried to install the 3.1.2 version via alien on the .rpm - but it fails with libc6 complaining about

/usr/bin/nautilus-actions-config-tool: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/libunique-3.0.so.0)

Here is the note from the developer

https://bugzilla.gnome.org/show_bug.cgi?id=647663
 nautilus-actions | general | 3.0.x

--- Comment #1 from Pierre Wieser <email address hidden> 2011-05-07 05:39:50 UTC ---
Created an attachment (id=187404)
 --> (https://bugzilla.gnome.org/attachment.cgi?id=187404)
Screenshow of a submenu opened on the desktop

The joined screen has been taken in released Ubuntu 11.04, with the latest
Nautilus-Actions 3.1.2.

As you can see, when clicking on the desktop, the Nautilus-Actions actions
normally appear in the submenu, and Nautilus-Actions submenu is normally
displayed.

Please update to latest versions.
If your behavior persists, please join your actions.

Regards
Pierre

Can you help with this problem?

Provide an answer of your own, or ask kylea for more information if necessary.

To post a message you must log in.