Rubbish Bin/Trash doesn't show deleted files

Asked by Mike M

Hi folks,

I'm running Ubuntu 10.10 but I noticed this in 10.4 too. When I delete a file (e.g. right click "Move to the rubbish bin") the file disappears and the trash/bin icon at the bottom of my screen or on my desktop shows some content graphically but when I right click and open the recycle bin I get a nautilus window showing my rubbish bin with no files. The restore button is grayed out but the empty button is enabled, the status bar says 0 items.

~/.local/share/Trash has two folders "info" which has a list of things I've deleted over time and "files" which stores 178 items taking up 135 Gb

Any ideas?

Thanks

Mike.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Mike M
Solved:
Last query:
Last reply:
Revision history for this message
ajmal_82 (ajmal-82) said :
#1

as far as my knowledge goes you might have checked the option inside nautilus to "enable delete command that bypasses trash" meaning when you delete a file it goes to trash
second option:
enable hidden files to be viewed inside nautilus i.e., ctrl+h
if this doesnt solve problem then report a bug .....

Revision history for this message
Mike M (mkmacdonagh) said :
#2

Thanks, but that option isn't checked and (as far as I know) never has been. Doesn't matter how I delete things they never go into Trash, and Ctrl+h didn't do the trick either.

Revision history for this message
Mike M (mkmacdonagh) said :
#3

The problem has gone away!

I'm not sure how it got resolved. I update all the time so maybe an update fixed it?
Alternatively two things I did were to:

- enable deleting things without going to trash
- cleared out the content of the physical trash ~/.local/share/Trash/files

Anyway, it now works!