Places folders all open Rhythmbox trick!

Asked by steve taylor

So I tried to install an unpacked tarball for Rhythm box by, right click, asking it to be opened using the Rhythm box program.
This is not a good idea. It's a Christmas, too many parties, thing to do.

The tar.gz was to suspend / shut down, when the last piece of music was finished, which I though would be cute at the time.

The novel result is that 'Places folders', all of them, open Rhythm box. Oops!

I am not that bothered, I have just un-installed Rhythm box and replaced it with GNOME MPlayer but I thought it worth sharing.

If I re-install Rhythm box the same thing happens so I guess buried somewhere in the system I changed some script so that all folders now try to open via Rhythm box.

Hopefully there won't be any further glitches.

(I have sussed tar unpacking now, please don't snow me with instructions)

Question information

English Edit question
Ubuntu nautilus Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best Emre AYTAÇ (eaytac) said :

You can use the following link, to solve your problem:

Or much simple way, right click a folder, Select Open With, Select Other Application, then select "File Browser" from list. After that your problem should solved. And also you can reinstall Rhythmbox.

Revision history for this message
steve taylor (stevemail) said :

Many thanks Emre,

after using ;
gedit ~/.local/share/applications/mimeapps.list

I get;

[Added Associations]




So where it says,

I should change it to


Revision history for this message
steve taylor (stevemail) said :

Brilliant Emre, worked like a charm.

Revision history for this message
steve taylor (stevemail) said :

Thanks Emre AYTAÇ, that solved my question.