Document Access from Places

Asked by Cariboo1938 on 2010-05-08

Fact:
Ubuntu 10.04 amd64 new installation.
/home directory is on separate partition from previous Hardy Heron installation.
Problem:
Difficulties when I try to access files/documents from
--->Places --->Home Folder.

When click on Home Folder, the window "Eye of GNOME Image Viewer" opens (Screen 01).
In that window I go to
->File ->open and immediately directory Pictures is selected (Screen 02).
When I select
->karibu ->Install-Documents again it tries to load image files, but there aren't any (Screen03).
In this window I select "All Files" and all the document files are shown (Screen 04).
When I select one of them for editing, i.e. CompizConf.txt, again the window "Eye of GNOME Image Viewer" opens (Screen 05).

The same happens with --->Places --->Documents, Music etc.

Please, can any body help ?!?

For Screenshots go to:
https://sites.google.com/site/jugrac/home/places-document_access-screens

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-05-09
Last query:
2010-05-09
Last reply:
2010-05-08
David Tomaschik (matir) said : #1

It looks like your gnome desktop is configured to load Eye of Gnome rather than Nautilus, the default file manager for Gnome. Try pressing ALT+F2, type in gconf-editor, and navigate to /desktop/gnome/session/required_components and ensure that filemanager is set to "nautilus". If not, you can double click on the value to change it.

Cariboo1938 (jgrauca) said : #2

Thanks, David...
I checked and there was nautilus attached to File Manager. See Screen 06 at
https://sites.google.com/site/jugrac/home/places-document_access-screens

Nothing changed though....Do I need to restart the computer?

Best Sam_ (and-sam) said : #3

What's the output of:
xdg-mime query default inode/directory

Update database:
sudo updatedb

Search for mimeapps.list:
locate mimeapps.list

e.g. rename it and restart X (logout-in):
mv ~/.local/share/applications/mimeapps.list ~/.local/share/applications/mimeapps.list.old

Verify the output:
cat ~/.config/user-dirs.dirs

Originals are in
/etc/xdg

Or undo menu settings in
~/.config/menus

Cariboo1938 (jgrauca) said : #4

Before I start doing update etc. I show you the terminal outputs. To me it's like Mandarin but maybe you can see better what to do....

1) xdg-mime query default inode/directory:
nautilus-folder-handler.desktop
root@karibu-desktop:~#

3) locate mimeapps.list:
/home/karibu/.local/share/applications/mimeapps.list
root@karibu-desktop:~#

5) cat ~/.config/user-dirs.dirs:
# This file is written by xdg-user-dirs-update......
#.............................. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Desktop"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"
root@karibu-desktop:~#

Sam_ (and-sam) said : #5

> To me it's like Mandarin

Can hardly believe it, because someone who is logged in as root usually knows exactly what he/she is doing.
Outputs look fine.

Cariboo1938 (jgrauca) said : #6

> To me it's like Mandarin.
What I mean is that I often don't know the general perspective. I'm not a programmer or software expert, by no means. I installed fresh from a self made LiveCD, on which the File browser works just fine. Anyway, I'll try what you recommended to do. Thanks for the trouble, keep you posted...

Cariboo1938 (jgrauca) said : #7

Thanks Sam, that solved my question.

Cariboo1938 (jgrauca) said : #8

I hadn't to go further than

1) Update database:
sudo updatedb and
2) Locate mimeapps.list, rename it and restart X (logout-in):
mv ~/.local/share/applications/mimeapps.list ~/.local/share/applications/mimeapps.list.old

By The Way: If somebody would ask me why it works after applying these commands I wouldn't be able to explain.
Thanks again for the help, Sam.

Sam_ (and-sam) said : #9

> why it works after applying these commands

Just for the record some background.
http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-0.9.4.html#mime-types

I have been away from my computer for a while and couldn't follow up on this problem. I have tried following the steps above but have had no luck. I also have been getting the following message: Modprobe:FATAL: Could not load /Lib/Modules/2.6.35-24-generic/modules.dep: No Such File or Directory. Is this in any way related to my inability to access any of the commands under desktop? I am able to access Desktop, Documents, Music etc. by going through computer and File system. This all has gotten very frustrating. I am sorry I am still a novice and need step by step instructions. If any more info is needed please let me know. Thanks - Mike