I have now tried to download three different applications and I get this message for each one. What am I doing wrong.?

Asked by Nigel Davis on 2010-05-03

End-of-central-directory signature not found. Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive. In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
note: /home/shop/2 Bejeweled 2 Deluxe - Full Version/2_BeJeweled 2 Deluxe - FULL VERSION.exe may be a plain executable, not an archive
zipinfo: cannot find zipfile directory in one of /home/shop/2 Bejeweled 2 Deluxe - Full Version/2_BeJeweled 2 Deluxe - FULL VERSION.exe or
          /home/shop/2 Bejeweled 2 Deluxe - Full Version/2_BeJeweled 2 Deluxe - FULL VERSION.exe.zip, and cannot find /home/shop/2 Bejeweled 2 Deluxe - Full Version/2_BeJeweled 2 Deluxe - FULL VERSION.exe.ZIP, period.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2010-05-05
Last query:
2010-05-05
Last reply:
2010-05-04
Pedro Villavicencio (pedro) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

The issue is that you are trying to run Windows applications in Ubuntu, which is a totally different operating system. The wine application allows you to run some (but not all) Windows applications more or less correctly.

See the following link for application compatibility info:

http://appdb.winehq.org/

In this case, you seem to be very lucky:

http://appdb.winehq.org/objectManager.php?sClass=version&iId=4300

So wine seems to support this game you are trying to install.

Good luck!

Nigel,

The file "2_BeJeweled 2 Deluxe - FULL VERSION.exe" is an .EXE file (intended to be installed in Windows), BUT this can be installed using a program called "wine."

Wine AppDB entry at:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=4300

1) Install wine using Ubuntu Software Center, Synaptic, or from command line with "sudo apt-get install wine".

2) Use wine to install the .EXE file (it's currently opening in Archive Manager).

Option A) The easiest directions for me to give are using command line "wine /home/shop/2\ Bejeweled\ 2\ Deluxe\ -\ Full\ Version/2_BeJeweled\ 2\ Deluxe\ -\ FULL\ VERSION.exe" _should_ work.

Option B) To use the File Manager in Gnome:
i) Right click on the .EXE file select Properties, go to the Permissions tab, and add a check to "Allow executing file as program".
ii) Right click the .EXE and select the option to run or open with Wine.

Best of luck,
George

Nigel Davis (nigeldavis) said : #5

thanks I was trying to download "sopcast" an internet tv viewing programme and mobileweb a dongle software. I am now stuck in Turkey and cannot download these programs which I need. Thanks for your help anyway

Nigel Davis (nigeldavis) said : #6

I was trying to download sopcast and mobile web dongle software. Seems like I am stuck. Thanks anyway

If we have sufficiently answered your original question, can you please set the thread status to "solved"? Thanks, Mark

Nigel Davis (nigeldavis) said : #8

Thanks Mark Rijckenberg, that solved my question.

Nigel Davis (nigeldavis) said : #9

Thanks to George Standish as well