Terminal opens in wrong directory

Asked by Sergey Zolotarev on 2012-12-07

When I enter a directory, move backwards and open a terminal via "Location options", the terminal opens in the subdirectory I previously visited rather than in the current directory. Is this intentional?

However If I right-click on the free space and Open Terminal from there, the directory is set correctly. I could do it like that if they didn't remove compact view from nautilus because there's no free space in list view if the list is full and the icon view is terrible and not usable at all.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nautilus-open-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-10-24
Last query:
2014-10-24
Last reply:
2012-12-07

When you open a terminal, run:

pwd; lsb_release -a; uname -a

What is output?

Thanks

Sergey Zolotarev (szx) said : #2

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux pc 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Sergey Zolotarev (szx) said : #3

I'm using PPA nautilus if that helps:

GNOME nautilus 3.6.3

And what is the output of:

pwd

when you first open a terminal?

Sergey Zolotarev (szx) said : #5

OK, it seems I wasn't clear enough. Here's what I do:

1. enter the "/usr" directory
2. enter the "bin" subdirectory so now I'm in "/usr/bin"
3. go back to "/usr" using the Back button (or mouse key in my case)
4. open "Location options" menu via the cogwheel button
5. click "Open in Terminal"
6. GNOME terminal opens up and its current working directory is set to "/usr/bin" (the dirctory I previously was in) rather than "/usr"

got it?

Also I noticed that "bin" is still present in the address bar (or whatever it's called) i.e. it doesn't change as I step back. Maybe it's somehow configurable? gconf-editor, etc?

I suggest you report a bug

Sergey Zolotarev (szx) said : #7

Thanks actionparsnip, that solved my question.