Post-install "500 Internal Server Error"

Asked by Kevin L. Nault on 2008-11-19

I just installed Ubuntu Intrepid server, and installed the cacti, cacti-spine, phpmyadmin, and nagios3 packages (with dependencies) through apt-get. phpmyadmin and cacti work great, but on login to nagios3 I get "500 Internal Server Error", and can't get it to reprompt me for credentials. The username/password I'm using are the ones I set up during install.

Basically, I'm stumped. All the directories referred to in /etc/apache2/conf.d/nagios exist with what look like perfectly acceptable permissions (owned by user and group nagios with read permissons for all users).

Am I authenticating wrong? Is something missing? Could a more useful error be generated?

The only mention of that error I can find with the word "ubuntu" is in some document at that never actually loads, so I'm stumped.

Question information

English Edit question
Ubuntu nagios3 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Kevin L. Nault (prof-morbius) said : #1

This issue persisted through a purge of the following packages and subsequent reinstall: libnet-snmp-perl libradius1 nagios3 nagios3-common nagios-images nagios-plugins nagios-plugins-basic nagios-plugins-standard nagios3-doc radiusclient1

Omegamormegil (omegamormegil) said : #2

I looked at the Ubuntu Community Documentation for Nagios2 here:

Just a guess, but from that the Initial Configuration in that doc:

"The configuration for authentication is in /etc/nagios2/apache2.conf. The default htpasswd file is /etc/nagios2/htpasswd.users, which does not exist upon installation. "

 cd /etc/nagios2/
 sudo htpasswd -c htpasswd.users nagiosadmin

Maybe you need to create that file? I'd recommend reading the rest of that doc. I don't know how much has changed between Nagios 2 and 3, though. Hope it helps.

Best Inigo (ubuntu-inigosoto) said : #3

I had the same problem as Kevin L. Nault, and Omegamormegil's solution worked just fine for Nagios 3. Looking at the apache log hinted that the password file wasn't being found


Kevin L. Nault (prof-morbius) said : #4

In fact, I ran this down quite a while ago, and forgot about this issue report!


I've been fine for a while.