How do I create a /dev/dvd link to make Mythbuntu 8.04 play DVDs?

Asked by Aaron Whitehouse

I am running Mythbuntu 8.04.

I have installed all the codecs/CSS packages, but MythTV (or Mplayer/VLC) can't play the DVDs. I believe that the error is that the programs are looking in /dev/dvd for the DVD and that does not exist on my system. I know that I need:
ln -sf /dev/??? /dev/dvd
but I don't know how to find out the sda/sdb device that corresponds to my DVD drive.

Also, how do I make the link permanent (survive a reboot)?

Why isn't a /dev/dvd created when Ubuntu is installed? The media players seem to use it. /dev/cdrom exists on the system and works correctly, why can't Ubuntu make a /dev/dvd that goes to the same place? Is this something that I should file a bug for?

Thanks a lot for your help.

Question information

English Edit question
Ubuntu mythtv Edit question
No assignee Edit question
Solved by:
Harvey Muller
Last query:
Last reply:
Revision history for this message
Best Harvey Muller (hlmuller) said :


If you check the /dev/cdrom symlink, it probably points to /dev/scd0. Assuming your dvd device is a dual cdrom/dvd device, then you can create a symlink that points to the same device the /dev/cdrom symlink points to. To verify the actual device your dvd/cdrom device points to, run in a terminal:

    $ ls -l /dev/cdrom

I'm not sure why the dvd device symlink is not being created. You can create a udev rule manually (beyond the scope of this question) to automatically create the device symlink on boot. Just google "write udev rules". A more permanent solution would be to open a bug. I recommend creating a kernel or udev bug, here's information to get you started:



Revision history for this message
Harvey Muller (hlmuller) said :


I am checking to see if the information I provided previously resolved your issu. If so, please mark the question Solved.



Revision history for this message
Aaron Whitehouse (aaron-whitehouse) said :

Thanks Harvey Muller, that solved my question.

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) said :

I was actually mistaken - /dev/cdrom was my CD writer and not my DVD writer. It seems that there was a /dev/dvd1 and a /dev/dvd+rw (I think), but no /dev/dvd.

I did the ls -l /dev/dvd1 and and it was /dev/scd1 (I think), so I did ln -sf /dev/scd1 /dev/dvd