Cannot set IP number in MythTV front end

Asked by TonyR on 2012-11-01

I am using Mythbuntu 12.04 with mythTV frontend 0.25.3 and on my backend server with has a static IP address (10.1.1.11) I can only connect from the front end on the same machine using either Localhost or 127.0.0.1. If I change it to 10.1.1.11 I get a database connection error.

To try to resolve this I have done the following.

1. Changed the /ect/mysql/my.cnf bind-address to 10.1.1.11 and made sure these was no skip-networking assigned anywhere in the file.
2. I ran the mysql commands to grant all on mythconverg to "10.1.1.%".

Needless to say the other clients on the network cannot conect either however the backend does all the time with either localhost ot the loop back IP number.

We dont know why it will not accept a static IP number. The Backend machine has a manual static IP number assigned which is reserved on the network and it is not using DHCP.

Any assistance would be most appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mythtv Edit question
Assignee:
No assignee Edit question
Solved by:
TonyR
Solved:
2012-11-01
Last query:
2012-11-01
Last reply:
2012-11-01

Does the system have internet access?

TonyR (rooneyo) said : #2

Yes.

I believe my problem is related to the SQL command I ran "grant all on mythconverg.* to mythtv"%" identified by "mythtv"

I did not realise that the indentified clause was creating a new password and was guided this way by the documentation that should have read - indetified by "the mythtv password assigned during setup". The doco was very misleading.

When I tried using the IP number of the backend in the frontend setup along with the password "mythtv" I was able to connect.

i read another thread where a user made the same mistake following the same documentation.

TonyR (rooneyo) said : #3

Hello

I believe my problem is solved and was related to the SQL command I ran "grant all on mythconverg.* to mythtv"%" identified by "mythtv"

I did not realise that the identified clause was creating a new password and was guided this way by the documentation that should have read - identified by [your password] - "the mythtv password assigned during setup". The doco was very misleading.

When I tried using the IP number of the backend in the frontend setup along with the password "mythtv" I was able to connect.

i read another thread where a user made the same mistake following the same documentation.

> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf
> Of actionparsnip
> Sent: Thursday, 1 November 2012 11:46 PM
> To: <email address hidden>
> Subject: Re: [Question #212956]: Cannot set IP number in MythTV front end
>
> Your question #212956 on gnome-nettool in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gnome-
> nettool/+question/212956
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Does the system have internet access?
>
> --
> To answer this request for more information, you can either reply to this
> email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/gnome-
> nettool/+question/212956
>
> You received this question notification because you asked the question.
>
>
> -----
> No virus found in this message.
> Checked by AVG - www.avg.com
> Version: 2012.0.2221 / Virus Database: 2441/5366 - Release Date: 10/31/12