Cannot configure Mythbuntu Msql database

Asked by roger layton

Mythbuntu 9.04.
I am an Ubuntu supporter, but I am losing it. Mythb is not user friendly!
I Have:
ASRock Conroe motherboard
Celeron 1.6 Ghz 64 bit
1Gb Ram
Nvidia GForce 7300 GT PCIe
Vstream Xpert TV PVR (Chipset Checked compatible)
Maxtor 80 Gb SATA listed primary HDD 0 (has successful install of Ubuntu Jaunty- 9.04)
Hitachi 250 Gb IDE Listed Secondary HDD 1
Liteon Combi burner SATA connected.

Attempted 8 installs onto the IDE reformatted after each.
Installation froze at 5% on first few. Burned another 5 CDs.
Tried 64 bit and 32 bit Torrents and desktop images and burned at 8X.
Bought another Combi drive.

Fully installed backend with the options:
249 Gb / and 256 Mb swap
X10 serial remote
Nvidia drivers
Primary Backend with frontend combined (common option)
Cannot connect to Mysql server
Is the backend running? Cannot communicate with server.
Entered the ip address for machine in local host.
“No uPNP backends found”
Tried again to configure with no luck.
QSql query::exec:database not open
QSql query::exec: database not open
2009-05-04 20:14:310 DB error (kickdatabase): query was:select NULL:
No error type from Qsql error? Strange…..
2009-05-04 cannot log in to database
2009-05-04 cannot log in to database

Abandoned after two days of trying and installed MythTV onto existing Ubuntu 9.04.after seeing it advised on the forum as an easier option. It was not.
Went through set up using the password and tried to configure MythTv with the result: Cannot communicate with backend is the backend running?

I am on the verge of giving up completely.
Have tried to access ~/.mythtv/mysql.txt
Got error 2002 (HY000)
Tried error fixes from other “(solved)” posts and have NEVER seen the front end work at all!

Question information

English Edit question
Ubuntu mythbuntu-common Edit question
No assignee Edit question
Solved by:
roger layton
Last query:
Last reply:
Revision history for this message
DaveThacker (dthacker9) said :

Is MySql running? Please type this at the command line <b> ps -ef | grep mysqld </b>

You should see something like the result below. (This is from my working mythbuntu 8.10 server)

dthacker@myth1:~$ ps -ef | grep mysqld
dthacker 2088 2035 0 08:41 pts/1 00:00:00 grep mysqld
root 4524 1 0 Mar16 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql 4566 4524 0 Mar16 ? 01:57:14 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/ --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 4568 4524 0 Mar16 ? 00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld

Revision history for this message
roger layton (roger-rogerlayton) said :

Thanks for the reply. This is what I get from that command:

root 2393 1 0 18:16 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql 2435 2393 0 18:16 ? 00:00:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/ --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 2437 2393 0 18:16 ? 00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
roger 4184 4140 0 18:22 pts/0 00:00:00 grep mysqld

It doesn't resemble your working config.....Looks like it's locked?

Revision history for this message
DaveThacker (dthacker9) said :

I think it's close enough. It looks like mysql is up and running. The next step is to verify that the mythbuntu database was created properly. Can you log into mysql from the command line using the default user and password that show in the myth setup screens?


Revision history for this message
roger layton (roger-rogerlayton) said :

Dave, Sorry about this I have now lost Myth after trying to re install, it does not do it.
I get: (after trying with synaptic)
E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10_i386.deb: subprocess pre-installation script returned error exit status 1

so I cannot even get into it's configuration. Could it be that the database has been set up and needs to be removed another way?
The Myth TV configuration interface was there yesterday, but now it's gone.

Revision history for this message
roger layton (roger-rogerlayton) said :

After another re install I discovered for the first time (out of 8 attempts) the pre start up configuration screen for XMLTV and grabbers etc. This did not appear before now on any previous attempts (5 disks). This explains why no database was configured I think. I realise that the listings are through Schedule Direct Open source but monthly paid subscription.
(not for me) This has no UK equivalent, so I will look at an alternative like XBMC etc.

Revision history for this message
roger layton (roger-rogerlayton) said :

thanks Dave