Error - broken dependencies

Asked by aL on 2011-09-26

I tried to install MySql Client but it didn't get install giving error.
Now when i want to install other things it says you have broken dependencies. Following are the messages which i get.

E: /var/cache/apt/archives/libmysqlclient16_5.1.41-3ubuntu12.10_i386.deb: trying to overwrite '/usr/lib/libmysqlclient.so.16.0.0', which is also in package mysql-cluster-client-5.1 0

When I run "sudo apt-get install -f" I get this error.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Done
The following extra packages will be installed:
  libmysqlclient16
The following NEW packages will be installed
  libmysqlclient16
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
Need to get 0B/1,933kB of archives.
After this operation, 4,248kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 289359 files and directories currently installed.)
Unpacking libmysqlclient16 (from .../libmysqlclient16_5.1.41-3ubuntu12.10_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libmysqlclient16_5.1.41-3ubuntu12.10_i386.deb (--unpack):
 trying to overwrite '/usr/lib/libmysqlclient.so.16.0.0', which is also in package mysql-cluster-client-5.1 0:7.0.9-1ubuntu7
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libmysqlclient16_5.1.41-3ubuntu12.10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do I repair this problem? Also tell me as to how this must have happened? I am running "ubuntu-10.04.3-desktop-i386" inside windows (Wubi)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mysql-5.1 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-09-28
Last query:
2011-09-28
Last reply:
2011-09-26

Packages don't like to step on other packages toes. You can however make it with:

sudo dpkg --force-all -i file.deb; sudo apt-get -f install

replace file.deb with the full path of the deb file in your error. You should also run:

ubuntu-bug libmysqlclient

to let the development team know about this conflict.

Before reporting this or other bugs in Ubuntu, please make sure to read https://help.ubuntu.com/community/ReportingBugs carefully.

aL (alkeshpradhan) said : #3

Thanks actionparsnip, that solved my question.

Remember to run:

ubuntu-bug libmysqlclient16

To report the issue