Can't access Mysql from local network

Asked by bill purvis on 2011-01-31

I've recently (last week) got round to updating one of my servers to Ubuntu 10.04 from 8.04. I think everything is
working OK, except for accessing mysql from my local network. I've set mysql to listen on the LAN and using
netstat -a I see exectly the same as my other server (still on 8.04):

tcp 0 0 arvo.billp.org:mysql *:* LISTEN
unix 2 [ ACC ] STREAM LISTENING 3672464 /var/run/mysqld/mysqld.sock

When I run 'mysql -h arvo' from another machine I get:
$ mysql -h arvo
ERROR 2003 (HY000): Can't connect to MySQL server on 'arvo' (110)

Can anyone suggest what I have overlooked?

Many thanks

Bill

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu mysql-5.1 Edit question
Assignee:
No assignee Edit question
Solved by:
bill purvis
Solved:
2011-02-03
Last query:
2011-02-03
Last reply:
bill purvis (bill-billp) said : #1

I have finally worked out for myself what was going on. For some reason, when I installed 10.4 it swapped around
my ethernet interfaces. I have two: one to the local net and the other to my ADSL router. I had installed iptables on the server
and the rules I had set up allowed anything from the local network but only FTP,SSL and HTML from the ADSL/Internet.

The penny finally dropped when I tried to run my backup script on my laptop and this failed as being unable to
contact the server. I normally use ssh to talk to the server, so I'd not noticed that the other ports were blocked.
I managed to rewrite the iptables config to switch ports and it now works OK.