How do I get 5.1.47 for lucid?

Asked by Andy on 2010-06-15

i need some of the mysql features contained in 5.1.47 release. I noticed this has been released for Maverick. When can we expect it for Lucid?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu mysql-5.1 Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-16
Last reply:
2010-06-17
Bilal Akhtar (bilalakhtar) said : #1

This is a new source package. The older version of the source package (mysql-dfsg-5.1) is in the lucid repos. It appears that this version probably won't arrive in Lucid (if it does, it will be an SRU, and that will come after a long time of testing). Ubuntu doesn't accept new releases of server packages into the repos so easily. If you still want the release, then please use the ubuntu backports repositories (WARNING: PACKAGES IN BACKPORTS MAY NOT BE VERY STABLE. These packages are not recommended in production environments) at your own risk.

Andy (abarringer) said : #2

This causes a huge problem for pretty much anyone needing a stable scalable MySQL platform.

Here's the problem in a nutshell. Anyone that has modern hardware and high io requirements must use the innodb_plugin. The plugin is only available in GA form at version 1.07. This version of the plugin ships with and is supported by MySQL 5.1.47.

We run only Ubuntu LTS releases for our database servers, that would be Lucid.

So we will have to wait years for a stable scalable Ubuntu+MySQL LTS setup... really?

Which means we either must abandon Ubuntu or MySQL. Or is there a middle ground somewhere that doesn't include "not recommended in production environments" tag?

Andy

Bilal Akhtar (bilalakhtar) said : #3

As I said, you should not wait for this specific version of MySQL to arrive in Lucid. The reason:

This version is generated from a new source package (new one: mysql, old one: mysql-dfsg-5.1), and Ubuntu doesn't allow *any* new (source) packages to enter repos after the version is released (Lucid). If you still want mysql 5.1.47, then please compile from source. Or use a PPA (I didn't find any PPA having mysql in them, as of now.)

In case, you need help in compiling from source, don't hesitate to contact me. You can ask for more help in the #ubuntu-server IRC channel on irc.freenode.net

Thank you for using Ubuntu.

Can you help with this problem?

Provide an answer of your own, or ask Andy for more information if necessary.

To post a message you must log in.