apache 2 : installation error

Asked by shashi on 2010-05-09

I installed ipplan to install apache2, php , and mysql services in ubuntu 10.04 64 bit.
when I opened server at "http://localhost/phpmyadmin" I got a red line error at bottom of the screen saying

The additional features for working with linked tables have been deactivated.
$cfg['Servers'][$i]['tracking'] ... not OK [ Documentation ]
Tracking: Disabled

how to enable this documentation?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu mysql-5.1 Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-09
Last reply:
2010-08-19

This question was originally filed as bug #577754.

Philip Muškovac (yofel) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.
If you can't get help here posting your issue in the Forums (http://ubuntuforums.org) would be a good idea.

Chris Johnson (raugturi) said : #2

I was able to clear this error on my setup by doing the following:

Step 1: Edit /etc/phpmyadmin/config.inc.php to point $cfg['Servers'][$i]['tracking'] to the right db by adding this line:

$cfg['Servers'][$i]['tracking'] = 'pma_tracking';

I'm not sure if there's a preferred place for it, I just put it immediately after the list of settings that contains history, designer_coords, etc.

Check now and see if this resolved it as this might be the only step you need. If it does not, proceed to Step 2.

Step 2: Try a different browser and/or clear your cookies if you're using Firefox. If that still isn't working, try Step 3.

Step 3: Make sure that /etc/phpmyadmin/config.inc.php is readable by www-data:

sudo chgrp www-data /etc/phpmyadmin/config.inc.php
sudo chmod g+r /etc/phpmyadmin/config.inc.php

Source: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=549474

You may need to repeat Step 2 again. Unfortunately I didn't find info on Step 2 until after I'd already tried the file permissions, so I honestly don't know if Step 3 was necessary.

Mikorist (mikorist-gmail) said : #3

this work after i add table `pma_tracking` in phpmyadmin db

Table structure for table `pma_tracking`

CREATE TABLE IF NOT EXISTS `pma_tracking` (
`db_name` varchar(64) collate utf8_bin NOT NULL,
`table_name` varchar(64) collate utf8_bin NOT NULL,
`version` int(10) unsigned NOT NULL,
`date_created` datetime NOT NULL,
`date_updated` datetime NOT NULL,
`schema_snapshot` text collate utf8_bin NOT NULL,
`schema_sql` text collate utf8_bin,
`data_sql` text collate utf8_bin,
`tracking` set('UPDATE','REPLACE','INSERT','DELETE','TRUNCATE','CREATE DATABASE','ALTER DATABASE','DROP DATABASE','CREATE TABLE','ALTER TABLE','RENAME TABLE','DROP TABLE','CREATE INDEX','DROP INDEX','CREATE VIEW','ALTER VIEW','DROP VIEW') collate utf8_bin default NULL,
PRIMARY KEY (`db_name`,`table_name`,`version`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin ROW_FORMAT=COMPACT;

Jackden (jackden) said : #4

in ubuntu 10.04
I use this command to create `pma_tracking` table.

CREATE TABLE IF NOT EXISTS `pma_tracking` (
  `db_name` varchar(64) collate utf8_bin NOT NULL,
  `table_name` varchar(64) collate utf8_bin NOT NULL,
  `version` int(10) unsigned NOT NULL,
  `date_created` datetime NOT NULL,
  `date_updated` datetime NOT NULL,
  `schema_snapshot` text collate utf8_bin NOT NULL,
  `schema_sql` text collate utf8_bin,
  `data_sql` longtext collate utf8_bin,
  `tracking` set('UPDATE','REPLACE','INSERT','DELETE','TRUNCATE','CREATE DATABASE','ALTER DATABASE','DROP DATABASE','CREATE TABLE','ALTER TABLE','RENAME TABLE','DROP TABLE','CREATE INDEX','DROP INDEX','CREATE VIEW','ALTER VIEW','DROP VIEW') collate utf8_bin default NULL,
  `tracking_active` int(1) unsigned NOT NULL default '1',
  PRIMARY KEY (`db_name`,`table_name`,`version`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin ROW_FORMAT=COMPACT;

Can you help with this problem?

Provide an answer of your own, or ask shashi for more information if necessary.

To post a message you must log in.